Open download functionality for executables should be added to Firefox

RESOLVED DUPLICATE of bug 253027

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED DUPLICATE of bug 253027
10 years ago
10 years ago

People

(Reporter: Liam K., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

The extension OpenDownload (https://addons.mozilla.org/en-US/firefox/addon/207) should be part of Firefox by default. As many people use it in Internet Explorer, it seems it works with the extension in Firefox, so I think it should be added by default.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
This feature was added in firefox 3 
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> This feature was added in firefox 3 
> 

No it wasn't...

Upon clicking on a download, the only two options are to save or cancel. No "run" or "open".
You mean for executables?
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> You mean for executables?
> 

For any file. From the description of the add-on:

"Allows you to open any file from the internet into the OS assigned program. This is similar to IE's 'Open' or 'Run' file download functionality.

NOTE: This does not support streaming. How it wors, is it downloads the file to your temp directory then launches it. Your operating system will then choose the default application to run it with. After 24 hours the file will automatically be deleted from your system."
Right, but for me, all files but executables can be opened, which is why I'm asking you to clarify that that's what you want.
(Reporter)

Comment 6

10 years ago
Oh, you're right. Yes, I mean executables. I didn't realize that Firefox had incorporated this functionality for other files.
(Reporter)

Updated

10 years ago
Summary: Open download functionality should be added to Firefox → Open download functionality for executables should be added to Firefox
In that case, it's a security feature which we don't plan on changing.  You'll have to use the add-on if you want to enable it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 253027
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.