Use Leopard-y folders on 10.5+

RESOLVED FIXED in Camino2.0

Status

RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: stuart.morgan+bugzilla, Assigned: stuart.morgan+bugzilla)

Tracking

unspecified
Camino2.0
x86
Mac OS X

Details

(Whiteboard: [camino-2.0])

Attachments

(3 attachments)

(Assignee)

Description

10 years ago
Filing UNCO for discussion, since I gather not everyone agrees it's a good idea: the more I look at our folder icons on Leopard, the more I feel like they contribute to giving the UI a dated look. I think we should consider using Leopard folder icons everywhere we show a folder in 10.5+.

Comment 1

10 years ago
We should actually, you know, discuss this soon. Like maybe at next week's meeting. :)

I'd be in favour of it, for the record.

Comment 2

10 years ago
Is this something that is still on the radar ?
I've made one for my own use, maybe that Leo-folder can be used. The one I've made is more desaturated than Apple's.

Comment 3

10 years ago
Created attachment 349691 [details]
Leo-folder screenshot

folder.tiff, groupbookmark.tiff, folder.png, up.png are the ones I made.
I think that is all what is needed.
(Assignee)

Comment 4

10 years ago
I was actually thinking of getting the actual folder icon from the OS at runtime, and having a stand-alone vertical bookmark icon to composite onto it. Either way, I prefer the bookmark-coming-out-of-the-folder look to the small badge though.
How would we handle the directory listing jar crap?  We can only choose one icon there. :(
(Assignee)

Comment 6

9 years ago
Taking to do comment 4. If anyone objects strongly to this idea, speak up ;)
Assignee: nobody → stuart.morgan+bugzilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #5)
> How would we handle the directory listing jar crap?  We can only choose one
> icon there. :(

I guess maybe we should file a bug on the directory listings and/or libimgicon to get folder icons from the OS just like it does file icons?

In the meantime, should we move everyone to 10.5-style icons in the dirListings, or leave them alone?

(In reply to comment #6)
> Taking to do comment 4. If anyone objects strongly to this idea, speak up ;)

I guess I don't object strongly to 10.5-style icons on 10.5, but I worry what happens when Apple switches to an awful, un-folder-y or poorly-angled icon again in a future release.
(Assignee)

Comment 8

9 years ago
Probably best to split directory listings out into a new bug, since it'll be implemented differently. I'm fine with switching people to 10.5-style statically, since it's the large-majority-and-growing of users.

(In reply to comment #7)
> I guess I don't object strongly to 10.5-style icons on 10.5, but I worry what
> happens when Apple switches to an awful, un-folder-y or poorly-angled icon
> again in a future release.

I thought about that, but Apple is very unlikely to switch folder icons in anything but a major OS release, so we should have plenty of warning to change the handling as needed.
(Assignee)

Comment 9

9 years ago
Created attachment 388165 [details] [diff] [review]
use OS folder icon on 10.5+

Finally got around to finishing this up.
Attachment #388165 - Flags: review?(trendyhendy2000)
(Assignee)

Comment 10

9 years ago
Created attachment 388166 [details]
badge image
(In reply to comment #8)
> Probably best to split directory listings out into a new bug, since it'll be
> implemented differently. I'm fine with switching people to 10.5-style
> statically, since it's the large-majority-and-growing of users.

Bug 503816.
Comment on attachment 388165 [details] [diff] [review]
use OS folder icon on 10.5+

Looks nice!
Attachment #388165 - Flags: review?(trendyhendy2000) → review+
(Assignee)

Updated

9 years ago
Attachment #388165 - Flags: superreview?(mikepinkerton)
Comment on attachment 388165 [details] [diff] [review]
use OS folder icon on 10.5+

sr=pink
Attachment #388165 - Flags: superreview?(mikepinkerton) → superreview+
(Assignee)

Comment 14

9 years ago
Landed on CVS trunk and CAMINO_2_0_BRANCH.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [camino-2.0]
Target Milestone: --- → Camino2.0
You need to log in before you can comment on or make changes to this bug.