If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

MP3 Flash player in FireFox stops playing MP3 when an Error connection occurred, the code tell the player to retry efvery 10 secs. BUT it's not work.

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: XelaBug, Unassigned)

Tracking

unspecified
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

OK, i've work very hard, and i've realized all that you need to try the problem.
here the link:

Internet Explorer 6/7 with the same Flash work very Fine.
FireFox 2: Not Work. (Linux & Windows)
FireFox 3*: Sometimes Works but taking a long time before it realize the problem.  (Linux to Bad than Windows)

*FireFox RC1 [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0]

[on-line page that do the error with Firefox and not with IE]
 http://www.xelabug.it/other/test-code/test-code.html


Reproducible: Always

Steps to Reproduce:
1.Open Page in IE and Firefox.
2.During play there is a loop between sound1 & sound2
3.Cause Error connection -> Unplug ETH cable!!!
4. See the debug textbox - Scroll (Drag) at the end or copy and paste all text in the text box.
5. » IE retry to connect for retreve mp3 endless every 5 sec.
6. » Firefox Stop here when it can't find the mp3 and nothing other events happend!
Actual Results:  
Firefox Stop here when it can't find the mp3 and nothing other events happend!

Expected Results:  
Retry to load the MP3 until the Connection resume.

See the Debug Box inside Flash player.
(Reporter)

Updated

10 years ago
Severity: normal → critical
Flags: blocking-firefox3?
Flags: blocking-firefox3.1?
Keywords: verifyme
OS: Windows XP → All
Not blocking final release of Firefox 3.0, which is in 2 hours. :)
Flags: blocking-firefox3? → blocking-firefox3-

Comment 2

10 years ago
Please don't CC 21 people at random...
You should only be CCing someone if you know they are or need to be involved.

For what it's worth, I could not reproduce this.  Unplug stops it; plugging back in continues the loop rather quickly.  (3rc2 on Linux)  What small delay I get is just my OS reconnecting things.

Is a sporadic dropped connection + Flash issue really even something that Firefox can do to much about, anyway?
Severity: critical → normal

Comment 3

10 years ago
Removing some CCs that are already getting all bug mail in the first place...

Updated

9 years ago
Keywords: verifyme

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Comment 4

9 years ago
Aside from the lack of follow up here, and the fact that I'm not convinced this is a Mozilla issue, the testcase is a 404 error. -> INCOMPLETE
Flags: blocking-firefox3.1?

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.