runtests.py throws error when platform.system() or platform.machine() is not known

VERIFIED DUPLICATE of bug 418640

Status

Tamarin
Virtual Machine
VERIFIED DUPLICATE of bug 418640
10 years ago
10 years ago

People

(Reporter: Dan Schaffer, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
runtests.py throws a KeyError when platform.system() or platform.machine() is unknown.  The code is trying to normalize different values but should not fail.  using try/catch should use the platform.system() or platform.machine() value and keep running.
(Reporter)

Comment 1

10 years ago
Created attachment 322769 [details] [diff] [review]
patch
Attachment #322769 - Flags: review?(brbaker)
(Reporter)

Comment 2

10 years ago
by the way the patch is for tamarin-central but we should do the same for tt not sure if the runtests.py are exactly the same.
Heh - I put a different patch in the other bug, at about the same time... two patches to choose from!  Nice problem to have. :)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 418640

Comment 4

10 years ago
Comment on attachment 322769 [details] [diff] [review]
patch

clearing the review flag as this bug is closed as a duplicate
Attachment #322769 - Flags: review?(brbaker)

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.