If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

event handling does not work on large SVG Elements

RESOLVED WORKSFORME

Status

()

Core
SVG
--
minor
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Armin Müller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

49.73 KB, application/x-zip-compressed
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9) Gecko/2008051206 Firefox/3.0

we change the position and size of an SVG element to the following size
x=-12800000% y=-12800000% width=25600000% height=25600000%
After this the event handling does not work any longer.

Reproducible: Always

Steps to Reproduce:
1. start index.svg
2. click plus-button
3. click on the map

Actual Results:  
=>nothing happens

Expected Results:  
Remove this lines from syslib.js
//THIS MAKES PROBLEMS
setAttributes(document.getElementById('panAndZoomRect'),{'x':'-12800000%','y':'-12800000%','width':'25600000%','height':'25600000%'});
click on the plus button
click on the map
=> you see an alert, coming from the mousedown event
(Reporter)

Comment 1

10 years ago
Created attachment 322789 [details]
example to demonstrate the bug
Regression window:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1175644560&maxdate=1175649179
Blocks: 374462

Comment 3

10 years ago
I suspect that this is not really an SVG problem directly but is due to limitations of the cairo rendering engine that gecko uses.

cairo's co-ordinate system range in firefox 3 is -2^24 to 2^24

I suspect this is a WONTFIX. The range has been extended from the firefox 2 which is 2^16


Updated

10 years ago
Component: General → SVG
Product: Firefox → Core
QA Contact: general → general

Comment 4

10 years ago
A more minimal example would be useful to confirm it is a 2^24 range issue.
Yep, could be 2^24, though it could also be an issue with in_fill() or extents().. a minimal testcase would certainly help.
(Reporter)

Comment 6

10 years ago
(In reply to comment #3)
> I suspect that this is not really an SVG problem directly but is due to
> limitations of the cairo rendering engine that gecko uses.
> cairo's co-ordinate system range in firefox 3 is -2^24 to 2^24
> I suspect this is a WONTFIX. The range has been extended from the firefox 2
> which is 2^16

Robert,

you are right. if have changed position and size from
x=-12800000% y=-12800000% width=25600000% height=25600000%
to
x=-7500000% y=-7500000% width=15000000% height=15000000%

Now it works. Thank you
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.