Opening same named files fails

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
10 years ago
4 years ago

People

(Reporter: David Balažic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

When one opens a link, then opens another link which has the same file name, the previous download is silently dropped.



Reproducible: Always

Steps to Reproduce:
1. Go to a page that links to multiple same named files, like a/x.zip and b/x.zip
2. click the first link, in the dialog choose "Open with.."
3. click the second link, in the dialog choose "Open with.."
Actual Results:  
The first download is canceled.

Expected Results:  
both downloads successfully complete and the file is opened.

On the specified URL, browse thru to download for some product and the use the links for different mirrors (Global, USA, Europe, China, Japan)

Updated

10 years ago
Whiteboard: DUPEME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
WFM on nightly, and at least as far back as 3.6, the second file is 
automatically renamed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.