CSS pseudo element :after and :before does not work on img-tags

RESOLVED DUPLICATE of bug 245633

Status

()

RESOLVED DUPLICATE of bug 245633
11 years ago
11 years ago

People

(Reporter: agwacc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5

The CSS pseudo element :after and :before does not work on img-tags in Firefox.
I searched for it on Google and it seems this bug is already known, but I saw no bug-report on it.
It seems that allowing for img:after / :before is correct W3C standard.

Reproducible: Always

Steps to Reproduce:
1. Use the CSS code (in Stylish or otherwise):
img:after{content:"test";}
Actual Results:  
Nothing

Expected Results:  
Text behind images.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 245633
You need to log in before you can comment on or make changes to this bug.