Reaches 1.2GB Memory Usage after sessionrestore with few saved pages, eventually hangs

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Lucius, Unassigned)

Tracking

({hang})

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

After restarting firefox with a few saved pages reopened, Firefox froze and I check the windows task manager. It's a surprise that firefox is running with 50% CPU and 500MB+ of memory and increasing. The biggest memory usage was 1.2GB, that's crazy. A few seconds after reaching that number windows alerts the system is running out of memory and firefox application is terminated.

There were actually 3 pages: wildguns.co.uk, gmail.com, worldofwarcraft.com/account in the first time. The first 2 pages do use a lot of javascript (which in my guess can cause all of those). But javascript wasn't really the problem because I tried opening wildguns.co.uk and this page bugzilla.mozilla.org it's the same. The number 1.2GB memory useage actually happened with these 2.

Take a look at 2 screenshots:

http://static.holvn.org/files/bugs/firefox_1.JPG
http://static.holvn.org/files/bugs/firefox_2.JPG

Reproducible: Always

Steps to Reproduce:
1.Start FF with a few pages
2.Close FF, choose yes to save pages for next open
3.Open FF again.
Actual Results:  
FF freezes, memory useage keeps increasing until out of memory.

Expected Results:  
keep it low !

I use firebug, this has been causing me a lot of problem too. Not sure if it's because of this addon.

FF version is 3.0 RC1
Firebug is known to cause problems with GMail and similar sites.

If you could try to recreate the problem with Firebug disabled, that would most likely demonstrate if it was a Firebug issue or a Firefox issue.

Also, which version of Firebug do you use?
(Reporter)

Comment 2

10 years ago
Firebug version was 1.1.0b12.

This bug, however, doesn't always happen. Actually after this, I stopped using the save pages function.

In the past I've had many experiences of FF for "not responding" after restoring last session. It's a nightmare restoring like 10+ webpages. I would suggest open all link at onces but load them one by one or the whole process will boom.

Comment 3

9 years ago
Lucius, do you still see this if you use FF 3.5 beta and new, empty profile (or safe mode)?
 http://www.mozilla.com/en-US/firefox/all-beta.html
Keywords: hang
Summary: Reaches 1.2GB Memory Useage on restoring Firefox with saved pages → Reaches 1.2GB Memory Usage after sessionrestore with few saved pages, eventually hangs
Version: unspecified → 3.0 Branch
(Reporter)

Comment 4

9 years ago
No, I don't. Frankly it's because I use FF less now (3 tabs only), switched to Chrome (10+ tabs).
well, WFM since impossible to get reproduced.
Severity: critical → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 6

8 years ago
a nit in the interests of accuracy, while digging into session store bugs - from the "reproduction" perspective, more appropriate than WFM (which should mean problem went away under similar circumstances) is incomplete (because reproduction wasn't really attempted) or invalid (on the assumption that the issue was firebug).
Resolution: WORKSFORME → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.