After upgrading to Firefox 3.0/image zoom and increasing font size inline images are rendered with wrong width/height

RESOLVED INCOMPLETE

Status

()

Core
Graphics
--
minor
RESOLVED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: Ariel Faigon, Unassigned)

Tracking

1.9.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-05-20], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052909 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052909 Firefox/3.0

Since upgrading to Firefox 3.0 on Linux I see images on Yahoo finance (classic) rendered incorrectly.  I believe the reason is that CTRL+ (increase font size) now also stretches images in a way that makes them look bad.

Go to the above URL and click CTRL+

Look at the text on the images and you can see that it is blurred (looks like some additional pixels on the horizontal dimension which make vertical font lines thicker).

When I do View source, I see the image has correct height/width parameters (512/288). Here's the embedded chart with the enclosing context:

<tr align="center" valign="top" bgcolor="white"><td colspan="6" bgcolor="white"><img src="http://ichart.finance.yahoo.com/b?s=SPY" width="512" height="288" border="0" alt="Chart for SPDRs (SPY)"><br><br><center>Splits:none</center></td></tr>

When I try 'view image', I see it rendered correctly in itself, so the image itself is correct.

Embedded in the page (above URL), it renders incorrectly.

Firefox 2.0 on the same page, renders fine regardless of font size setting.


Reproducible: Always

Steps to Reproduce:
1. Go to the above URL with Firefox 3.0
2. CLick CTRL+ to increase text size by one notch
3. Notice image is 'stretched'
4. Look at the text on the chart
5. If text looks garbled (stretched or squished) you've reproduced the bug
Actual Results:  
Text on embedded image looks garbled, and some vertical lines look thicker than others. Image looks "ugly".

Expected Results:  
increasing text size doesn't try to stretch image.
For that we have image zoom.

Comment 1

8 years ago
A.F. Do you still see this with Fx 3.6?   Using 3.7 trunk I see some fuzziness of text, but nothing that looks like garbled or stretch marks :)

If you see this, a screen shot of what you see, attached to the bug, would be best. If you don't see this, please close bug with resolution set to WORKSFORME
Severity: normal → minor
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Whiteboard: [closeme 2010-05-20]

Comment 2

7 years ago
Closing since now after whiteboard closeme date and no reply to last comment.

Please reopen/comment with further info, if you still see this issue with Firefox 3.6.13 or later in safe mode:
http://support.mozilla.com/kb/Safe+Mode

If you wish, you can also try to reproduce in Firefox 4 Beta 8 or later:
http://www.mozilla.com/en-US/firefox/all-beta.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
Version: unspecified → 1.9.0 Branch
You need to log in before you can comment on or make changes to this bug.