SNAV fails to get 'content window' on fennec

VERIFIED FIXED

Status

VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: tonikitoo, Assigned: mfinkle)

Tracking

({mobile})

Trunk
x86
Linux
mobile

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

11 years ago
svan tries often to get a 'window content' from a 'chrome window' object [1], but if we try to make snav to work on fennec. 

[1] http://lxr.mozilla.org/seamonkey/source/extensions/spatialnavigation/src/nsSpatialNavigation.cpp#840

fwiw, the same code works fine on Firefox 3 (with patch https://bugzilla.mozilla.org/attachment.cgi?id=322650 applied)
Created attachment 323023 [details] [diff] [review]
Make sure we use type="content-primary" when needed

I am fairly certain that nsGlobalWindow::GetContent eventually needs the <browser> to have a type="content-primary". This patch sets the type correctly when needed.
Assignee: nobody → mark.finkle
Status: NEW → ASSIGNED
Attachment #323023 - Flags: review?(gavin.sharp)
(Reporter)

Updated

11 years ago
Blocks: 347731
(Reporter)

Comment 2

11 years ago
mfinkle, patch virified. SNAV worked fine after. Thanks.

btw, is it supposed to fix bug 435446 ? should we add a dep here ?
this has been fixed in the latest fennec.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Attachment #323023 - Attachment is obsolete: true
Attachment #323023 - Flags: review?(gavin.sharp)

Comment 4

8 years ago
VERIFIED FIXED:

Build ID: Mozilla/5.0 (Maemo; Linux armv7l; rv:6.0a1) Gecko/20110510
Firefox/6.0a1 Fennec/6.0a1

Device: Nokia N900 (Maemo GTK)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.