Button changes when in focus

RESOLVED DUPLICATE of bug 427020

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 427020
10 years ago
10 years ago

People

(Reporter: Jamie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0

I have been using the input:focus style for a few sites that I have been working on.  Now that Firefox is trying to make the browser more like the OS, the button is changing from looking like an OS X button, to a normal button when the button is in focus.  

This does not happen in Safari.  If you click on the "test" button in the link provided, you will see how the button changes.  When you leave focus, the button goes back to looking like an OS X button.

Reproducible: Always

Steps to Reproduce:
1. Click on the test button
2. Click anywhere else on the page to get focus off the button.
Actual Results:  
Changes the button style

Expected Results:  
Button should stay the same.

Comment 1

10 years ago
Can you attach a minimal test case to this bug (using the 'Add an attachment' link above) ?
I receive a network time out error when following the link in the URL field.
(Reporter)

Comment 2

10 years ago
Created attachment 323062 [details]
Page that displays the error

This is the file that contains the style and the button that I am having problems with.

Updated

10 years ago
Attachment #323062 - Attachment mime type: text/plain → text/html

Comment 3

10 years ago
Thanks for the test case. Not pretty...

That is the same issue as bug 427020.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 427020
You need to log in before you can comment on or make changes to this bug.