Closed Bug 436380 Opened 12 years ago Closed 7 years ago

add advanced search builder to the Library

Categories

(Firefox :: Bookmarks & History, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 59173

People

(Reporter: dietrich, Unassigned)

References

Details

 
In bug 422977, the "query builder" was disabled from the Library. It should be improved and enabled.
Depends on: 424542
Depends on: 416010
Depends on: 393510
UI spec and discussion in bug 393510.
Priority: -- → P1
Target Milestone: --- → Firefox 3.1
Blocks: 437246
Duplicate of this bug: 425804
Priority: P1 → P2
(In reply to comment #2)
> UI spec and discussion in bug 393510.

Since faaborg seems to have killed that in bug 393510 comment #10, should this also be INVALID'ed?

Is there any point in an enhancement request for a way to save complex tag queries, or is that pretty much addon territory now? TagSifter works a treat for querying, but neither it nor Tag Finder has a way to save/bookmark the queries, AFAIK.



This bug is the enhancement request for UI creating/editing complex queries. Alex just made the 3.0-specific tracking bugs INVALID. We can still use them for reference.

As far as I'm concerned, including tag-query support in the search builder is a requirement. I'll add the dependencies for doing so to this bug.
Depends on: 399799
This bug is on the nice to have features list. Asking for wanted Firefox 3.1
Severity: normal → enhancement
Flags: wanted-firefox3.1?
No longer blocks: 437246
Target Milestone: Firefox 3.1 → ---
Duplicate of this bug: 418224
Flags: wanted-firefox3.5? → wanted-firefox3.6?
I'm not sure this still makes sense as it was designed, see new Faaborg's mockups for 3.7 and 4.0.
Btw, the current query builder code is old and bitrotted and the querying API is too limited, so i'm just going to remove it in Bug 367991.
If we are going to reintroduce something like that we should make it better and use a better query API. I also would like to point out that it is not a "can't live without" feature, and there are some extensions providing it for advanced users.
Flags: wanted-firefox3.6?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Duplicate of this bug: 660178
can we create a smart bookmark base on "frecency", the same as URL bar drop down?

The Places frecency algorithm - MDC Docs
https://developer.mozilla.org/en/The_Places_frecency_algorithm
not in the current Library, we just globally need better search tools, maybe new in-content pages will add, but not like this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 59173
You need to log in before you can comment on or make changes to this bug.