Closed Bug 43641 Opened 20 years ago Closed 16 years ago

Ability to browse froward (pre-cache Web resources) (load in background)

Categories

(SeaMonkey :: General, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jasonab, Unassigned)

Details

(Keywords: helpwanted)

I know this is somewhat pie-in-the-sky until you land the final beta, but I
would like to be able to mark links as "to be read," and have the browser pull
and cache those pages automatically. That way I could go to the CNN homepage,
mark the ten articles I wanted to read, and have them cache on my machine while
I'm reading the first one, eliminating the whole "back then forward again"
mechanism, with it's requisute delays and constant (slow) DNS lookups.
this is already filed somewhere.  will try to find it.
dupe of bug 11632


*** This bug has been marked as a duplicate of 11632 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
I respectfully disagree with the duplicate resolution. The bug this is marked as 
a duplicate as is simply saving pages to disk. In this issue, I'm referring to 
automatic spidering by the browser based on user selection. While I agree that 
the functionality is the other bug is probably a prerequisite, I believe there's 
more to this issue.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
OK, I think I see what you're saying.Tell me if I'm way off.  You'd like some
way to select a link (via a context menu or a checkbox that gets laid out in the
page next to every link) that would allow you to select/mark a number of links
on a page taht would be cached in the order you linked them and available for
viewing via a history-like window?  How close am I?
Exactly. I'm thinking of something like CNN or ESPN, where I come to the front 
page, and instead of having to go back and forth, reloading the front page 
constantly, I'd rather download everything at once (more or less), saving 
bandwidth and time.

For example, say I come to CNN, and I see five articles I'd like to read. 
Currently, I have to click on the first one, do a DNS lookup, load the page 
(including all the elements), and read. Then, I have to go back, reload the 
front page, and select the second page, loadng everything there. And so on, and 
so on....

With this feature, I could select all five links I wanted to read. While I'm 
reading the first article, the other four are downloading in the background, and 
I select those from a list when I want. This saves me from reloading the front 
page four times, and allows for smoother navigation of the site.
ok, I get it. adjusting summary with the addition of [RFE], adding 
helpwanted keyword and assigning to nobody until someone picks this up and gives 
us some code.
Assignee: asa → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Summary: Ability to set forward browsing preferences → [RFE] Ability to set forward browsing preferences
I'd really like this, and i think i've found a way to implement this and that
would be really logical for the user to understand: Instead of having a checkbox
/ radio button / whatever next to each link, why not have a personal
toolbar-like bar where the user can drag-and-drop the (for this example) CNN
article links. The links then appear like in the personal toolbar, and start
downloading immediately. Obviously, you'd need a default button to get back to
the page you are REALLY at.
The toolbar sounds interesting, but what I'd most like is to have it on the 
right-click menu. Both is doable, of course.
See also:

bug 18213 to-do list that would be able to contain urls
bug 56690 "open link behind current window" option
Summary: [RFE] Ability to set forward browsing preferences → Ability to browse froward (pre-cache Web resources) (load in background)
Since we now have tabbed browsing, could this bug not be considered fixed? 
Being able to load tabs in the background certainly comes close to my original idea.
marking WFM as per comment 11.
Status: NEW → RESOLVED
Closed: 20 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.