Closed Bug 436483 Opened 13 years ago Closed 5 years ago

Firefox doesn't detect incompletely loaded images due to network timeouts

Categories

(Core :: Networking: HTTP, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: alicebot, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [lame-network])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

I often load a lot of images in several tabs at once. Unfortunately, this is too much for my network connection, and many of the images don't finish loading (they stay only partly loaded). Normally, this should make the "Show image" context menu available - unfortunately, Firefox seems to think that it has recieved the whole file, the context menu isn't displayed and the only thing that helps is View image + refresh via ctrl-f5.

I think this could be related to servers not sending the image file size (if i right click the properties on the unfinished image, it shows a filesize that's smaller than the actual filesize).

The show image menuitem works normally on http error pages (404, 403...), during loading of images, and if I manually stop loading the image using the escape key - it only seems to be an issue with network timeouts.

I'm trying to make some kind of testcase, unfortunately it's hard to artificially reproduce the situation. 

Reproducible: Always

Steps to Reproduce:
1. Open a website with lots of large images on a relatively slow and unreliable connection (512kbps wifi)
2. Wait until the page stops loading
3. Look for images that are only partially loaded
4. Try to reload them with the show image context menu option
Actual Results:  
The "Show image" context menu is missing

Expected Results:  
The "Show image" context menu is present

This blocks bug 218142.
Blocks: 218142
Can you provide a sample link of a website with such images which causes the
problem to appear?
Component: Menus → Networking: HTTP
Product: Firefox → Core
QA Contact: menus → networking.http
Version: unspecified → Trunk
Yes, but it'll take a while because it's mostly happening on private discussion forums where people post images hosted on imageshack & co, and I don't want to repost those pictures publicly for privacy concerns (I could prepare something and send you the link via e-mail).

In the meantime, I'll try to set-up an artificial test case using a PHP script that stops sending data halfway through the file and see if I can reproduce the behaviour that way, instead of on "real" data (this would also help because it could be turned into an automated testcase later on).
Ok, here goes... I made an html page with about 300 images hosted on various websites, every time i reload the page with ctrl-f5, some images don't get loaded properly (the tenth from the top, z6-2-3.jpg, seems to not load fairly consistently on my machne, opening it in a separate tab and ctrl-f5 helps).

The url is http://sweb.cz/alicebot/firefox/testcase-436483.html (all the images are fractals, I didn't made them, I just collected them on a single webpage).
Sorry for the late feedback here.  I can confirm the problem on 3.0 release:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

and the latest nightly:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a1pre) Gecko/2008071203 Minefield/3.1a1pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
Lately either my internet connection has deteriorated or the new Firefox is broken, but it's getting worse. I'm getting silently aborted "loads" not only for images in web pages, but for web pages themselves (the page just stops loading as if it has finished, but it hasn't), but also for regular downloads (731KB of 11MB with no indication of error and no option to "redownload"). Looks like the streams just end prematurely, and Firefox is OK with that (even if it knew the size of the download in advance).

I'm using the latest 3.5 Preview:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99 (.NET CLR 3.5.30729)
Blocks: 715399
Whiteboard: [lame-network]
unfortunately we've found out that we need to treat truncated as OK for webcompat.. there is a lot of content that is simply always truncated wrt official framing rules
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.