Update search engine plug-in favicon for Google

VERIFIED FIXED in Firefox 3.1b2

Status

()

VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: kohei, Assigned: Gavin)

Tracking

({polish, verified1.9.1})

Trunk
Firefox 3.1b2
polish, verified1.9.1
Points:
---
Bug Flags:
blocking-firefox3 -
blocking-firefox3.5 +
wanted1.9.0.x -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-easy][polish-visual][polish-p1][icon-shiretoko])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
+++ This bug was initially created as a clone of Bug #421613 +++

http://blogoscoped.com/archive/2008-05-30-n48.html
http://www.google.com/favicon.ico
Flags: wanted1.9.0.x?
Flags: blocking-firefox3?

Updated

11 years ago
Blocks: 436501
(Reporter)

Comment 1

11 years ago
This may affect user experience in any way because Google icon is always shown in the search bar. I think the change should be made with 3.0 rather than 3.0.1.

Updated

11 years ago
No longer blocks: 436501
We're not going to respin FF3 for this, sorry.  Assigning to kev to figure out if we should update, or get the icon if we should.
Assignee: nobody → kev
Flags: blocking-firefox3? → blocking-firefox3-

Comment 3

11 years ago
This would be a .next add if it's official. We had asked Google for updated favicons, and the squared G was what was provided (Mic/Axel please confirm, it's what I have). I don't look at it as critical, as users are accustomed to the squared G for google, and that is the branding they provided to us. 

I'll inquire if the new branding should be considered for future releases, but the squared G was what was given for Fx3.

Comment 4

11 years ago
Yeah, the squared G is what we got in bug 429232.
fwiw, it's a pretty simple update; I put the data url for the new icon in the URL field.

Updated

11 years ago
Duplicate of this bug: 436655

Updated

11 years ago
Summary: update search plugin icons for Google → Update search engine plug-in icon for Google

Comment 7

11 years ago
It's a simple update, but we ask the providers for permission first, since it's there marks, and I want to make sure this is a permanent change and not a trial. I have asked Google to verify that this would be desired. PSO is checking in on it, and I've also asked Alex to review to see if the new favicon is ok as-is for fitting in with the chrome (there's some funky bevel/drop shadow which, too me, aren't optimal, but that may be personal pref), or if we need to request tweaks.

Created attachment 323375 [details]
New google favicon at 100% and 500% on all platforms

The background gradient on their new favicon (from white on the top to grey on the bottom) does not work that well when overlaid on a textured button.  I recommend we ask them for just the g part of the new favicon.  If we could get them to use platform colors (for instance the correct gray scale gradient on OS X), that would be ideal.  However, I don't imagine that they will go for the idea since this image is strongly tied into their brand.

Comment 9

11 years ago
Alex, I'm not fond of the idea to ship platform dependent search plugins for google.

For google.xml, a gradient-free version would work best, IMHO.

We could wait if it sticks, too ;-).
>Alex, I'm not fond of the idea to ship platform dependent search plugins for
>google.

Personally I would like any search plugin icons used in a range of different locales to move to be part of the theme as pngs instead of cdata in an xml file to allow for this level of platform dependent customization.

Comment 11

11 years ago
(In reply to comment #8)
> If we could get them to use platform colors
>

The icon's background gradient it mostly transparent, and whatever background the icon sits atop bleeds through, so I don't think there is much of a need for this.

> We could wait if it sticks, too ;-).
> 

Yea.  Hopefully, Google has taken a random sample of the reactions to this and noticed how overwhelmingly negative it's been.  :)  </wishful_thinking>
(In reply to comment #8)
> Created an attachment (id=323375) [details]
> New google favicon at 100% and 500% on all platforms
> 
> The background gradient on their new favicon (from white on the top to grey on
> the bottom) does not work that well when overlaid on a textured button. 

You know we're talking about the icon for the searchplugin, right? Your mockups are showing it overlaid on the site identity button. I'm guessing that's just because they're convenient.

(In reply to comment #10)
> Personally I would like any search plugin icons used in a range of different
> locales to move to be part of the theme as pngs instead of cdata in an xml file
> to allow for this level of platform dependent customization.

Is that bug on file? Let's not tie this to that, though.

Kev: can you reach out to our Google contacts and ask them what they'd like us to do, and whether we can customize the gradient?
>You know we're talking about the icon for the searchplugin, right? Your mockups
>are showing it overlaid on the site identity button. I'm guessing that's just
>because they're convenient.

yep

>Is that bug on file? Let's not tie this to that, though.

I agree we shouldn't tie the two, there isn't a bug on file yet (part of a much larger icon organization that we should eventually do).

Comment 14

11 years ago
I'm not sure if searchplugin icons are really in the same bucket as general theme icons, with trademarks and all, but that's really a different question. CC me when you file those bugs?

Updated

11 years ago
Duplicate of this bug: 437211
Summary: Update search engine plug-in icon for Google → Update search engine plug-in favicon for Google
Kev, any update here?
Flags: wanted1.9.0.x? → wanted1.9.0.x+

Comment 17

10 years ago
Created attachment 334337 [details]
Google-submitted favicon for search plugin

Apologies, I received this last week and didn't update. Here is the favicon Google has provided to us for use with the default search plugin.
Attachment #323375 - Attachment is obsolete: true
Thanks Kev. Gavin, can you own this?
Assignee: kev → gavin.sharp
Status: NEW → ASSIGNED
Requesting blocking since shipping the outdated google icon in a new Firefox release subtlety conveys to the user that Firefox is out of date.
Flags: blocking-firefox3.1?
Keywords: polish
Whiteboard: [polish-easy][polish-visual][polish-high-visibility]
Whiteboard: [polish-easy][polish-visual][polish-high-visibility] → [polish-easy][polish-visual][polish-high-visibility][icon-3.1]
Created attachment 346178 [details] [diff] [review]
patch
Attachment #346178 - Flags: ui-review?(beltzner)
Attachment #346178 - Flags: review?(mconnor)

Updated

10 years ago
Attachment #346178 - Flags: review?(mconnor) → review+
Attachment #346178 - Flags: ui-review?(beltzner) → ui-review+
Attachment #346178 - Flags: approval1.9.1b2?

Updated

10 years ago
Attachment #346178 - Flags: approval1.9.1b2? → approval1.9.1b2+
http://hg.mozilla.org/mozilla-central/rev/5b934cbdcefb
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1b2
Flags: blocking-firefox3.1? → blocking-firefox3.1+
Keywords: fixed1.9.1
Flags: wanted1.9.0.x+ → wanted1.9.0.x-

Updated

10 years ago
Duplicate of this bug: 472901

Comment 23

10 years ago
Google has updated their Favicon again.  Do we re-open this bug or file a new one?

http://googleblog.blogspot.com/2009/01/googles-new-favicon.html
(In reply to comment #23)
> Google has updated their Favicon again.  Do we re-open this bug or file a new
> one?

Neither. See bug 472901.

Comment 25

10 years ago
Verified fix on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US;
rv:1.9.1b3pre) Gecko/20090122 Shiretoko/3.1b3pre 
and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre)
Gecko/20090122 Minefield/3.2a1pre

in addition, i checked it on windows and linux trunk & branch builds as well.
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
This bug's priority relative to the set of other polish bugs is:
P1 - Polish issue that appears in the main window, or is something that the user may encounter several times a day.

This changed impacted the main window, and users will probably notice that the icon is a bit more garishly branding the search field now (especially in an otherwise entirely monochrome theme on OS X).
Whiteboard: [polish-easy][polish-visual][polish-high-visibility][icon-3.1] → [polish-easy][polish-visual][polish-p1][icon-shiretoko]
Actually the last comment was intended for bug 436497 (they updated twice).
You need to log in before you can comment on or make changes to this bug.