Spellchecker incorrectly flags "cancelled" as misspelled

RESOLVED FIXED

Status

()

Core
Spelling checker
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: u71076, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 479334])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20061201 Firefox/2.0.0.14 (Ubuntu-feisty)
Build Identifier: version 1.5.0.14ubu (20080505)

The spellchecker in Thunderbird flags the word "cancelled" as misspelled, which it is not.

Merriam Webster says that the word 'cancelled' may be spelled with either one or two L's (http://www.merriam-webster.com/dictionary/cancelled). Both versions
are legitimate in US English.

In fact, the version with two L's appears to be the most commonly used (http://www.googlefight.com/index.php?lang=en_GB&word1=cancelled&word2=canceled).

Reproducible: Always

Steps to Reproduce:
1. Compose a message containing the word "cancelled".
2. Run spell check.
Assignee: nobody → mscott
Component: Message Compose Window → Spelling checker
OS: Linux → All
Product: Thunderbird → Core
QA Contact: message-compose → spelling-checker
Hardware: PC → All

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 241181
(Reporter)

Comment 2

10 years ago
I don't believe this bug is a duplicate of bug 241181 and I would request that it be reopened. Bug 241181 seems to be about the spelling of the word "cancelled" in the Mozilla UI and source code.

This bug is about a bug in the dictionary used by the spell checker. The "cancelled" spelling should be added to the dictionary independent of the outcome of bug 241181.
(Reporter)

Updated

10 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

10 years ago
Assignee: mscott → nobody

Comment 3

9 years ago
Yup, http://www.merriam-webster.com/dictionary/cancelled agrees "cancelled" is a legitimate inflected form.  Firefox 3.1 nightly also flags "cancelling" as misspelled.

I don't fully understand en-US.dic rules and flags despite reading "Hunspell features" doc on the web, but I believe
cancelled/U
canceller/M
(allowing the affixes uncancelled and canceller's just like uncanceled and canceler's ) should be added to en-US.dic

Comment 4

9 years ago
Sorry, and add
cancelling

The patch (?) is
--- en-US.dic.org       2008-10-06 14:34:05.750000000 -0700
+++ en-US.dic   2008-10-16 15:44:22.546875000 -0700
@@ -20887,2 +20887,5 @@
 cancellation/MS
+cancelled/U
+canceller/M
+cancelling
 cancer/MS

Comment 5

9 years ago
Seems reasonable. Adding 

cancelled/U
canceller/M
cancelling

as part of bug 479334.
Status: UNCONFIRMED → NEW
Depends on: 479334
Ever confirmed: true

Comment 6

8 years ago
There was also bug 423445 on the same issue.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 479334]
You need to log in before you can comment on or make changes to this bug.