Firefox is not deleting certificate authority (CA)

RESOLVED DUPLICATE of bug 173729

Status

()

RESOLVED DUPLICATE of bug 173729
11 years ago
4 years ago

People

(Reporter: morid_rhosard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupeme)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008053006 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008053006 Minefield/3.0pre

The problem deleting certificate authority is if you try to import the same deleted certificate, Firefox says that certificate is already installed when it should be deleted.

Reproducible: Always

Steps to Reproduce:
1. Go to Tools - Advanced Tab - View Certificates.
2. Under Certificate Manager, try to delete ABA ECOM Root CA certificate.
3. Restart Firefox. (Closing and restarting Certificate Manager without full restart happens as well)
4. "Deleted" certificate is back.
Actual Results:  
There is no real deletion.

Expected Results:  
It should be possible to delete certificate authority (CA) and import them again.

I cannot reproduce with VeriSign certificates.

Updated

11 years ago
Whiteboard: dupeme
as of today it's not possible to delete certificates contained in the builtin software token.

when you delete it, we simply remove its trust

there is already a bug on file that requests improving the user experience
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

9 years ago
(In reply to comment #1)
> there is already a bug on file that requests improving the user experience

I think you are referring to bug 173729.
I waste some time trying to find it so I link it here for reference.
IMHO, the current behavior is really inconsistent and a fix is absolutely needed.
reassign bug owner.
mass-update-kaie-20120918
Assignee: kaie → nobody

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 173729
You need to log in before you can comment on or make changes to this bug.