Invalid debugger statement handling in the interpreter loop

RESOLVED FIXED

Status

Rhino
Core
--
minor
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Alexander Chebanenko, Unassigned)

Tracking

head
x86
Windows XP

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: 1.7R1

Package org.mozilla.javascript, class Interpreter, line 3755. 'break Loop;' should be changed to 'continue Loop;'. 
Currently after the JS debugger has been stoped on 'debugger' statement, script execution halts because of the break operator in the interpreter loop. 
This issue is still in CVS (I've checked it against Interpreter.java, v 1.3).

Reproducible: Always

Steps to Reproduce:
1. Write simple javascript, like 'x = 2+2; debugger; var y = x*2;'
2. Run the script mentioned above in the debugger.
3. Debugger will stop execution on 'debugger' statement
4. Press step over to move to the next line (calculation of the y).

Actual Results:  
Debugger finishes executing the script

Expected Results:  
Debugger moves to the next line and calculates y variable.
(Reporter)

Updated

10 years ago
Version: other → head

Comment 1

9 years ago
Created attachment 345680 [details] [diff] [review]
patch

Confirming bug and suggested fix.

Comment 2

9 years ago
Checking in src/org/mozilla/javascript/Interpreter.java;
/cvsroot/mozilla/js/rhino/src/org/mozilla/javascript/Interpreter.java,v  <--  Interpreter.java
new revision: 1.350; previous revision: 1.349
done
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.