Enable using regular folder names on IMAP server for special folders

RESOLVED INVALID

Status

Thunderbird
Preferences
--
enhancement
RESOLVED INVALID
10 years ago
7 years ago

People

(Reporter: Renaud Métrich, Unassigned)

Tracking

({imap-interop})

imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5
Build Identifier: version 2.0.0.14 (20080505)

My email provider (www.laposte.net) provides email supporting IMAP but uses special names for the Thunderbird special folders Sent, Draft, Junk, etc. This makes Thunderbird creates additional folders on the IMAP server, which is very annoying.
Whereas it is possible to change the Trash folder name using the mail.server.default.trash_folder_name preference, it seems it is not possible to change other special folder names, such as Sent, Draft and Junk.
Would it be possible to have this functionality in next Thunderbird releases, for example by letting the user choose which folder *is* some special folder by clicking on the Properties item of the folder and by having a new list, say "Special Folder", where the user could choose what it actually is.

Example:
1. user right-clicks on the QUARANTINE folder (which is Junk on some IMAP servers)
2. user choose Property
3. user goes to a new Tab, say "Special Folder"
4. user chooses in the list which special folder it is:
    Junk -- Sent -- Draft -- None ...


Reproducible: Always
(Reporter)

Updated

10 years ago
Keywords: interop
Version: unspecified → 2.0

Comment 1

10 years ago
Settings for Sent, Drafts, Junk are right there in the Account Settings under Folders & Copies ...

->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(In reply to comment #1)
> ->INVALID

"INVALID" is invalid, because request on Trash is valid.

To Renaud Métrich(bug opener):

Current UI and UI in trunk for non-Tb's-standard folder is as follows.
 (A) Sent, Drafts, Templates, Junk
     (A-1) Sent, Drafts, Templates :
           Choice in "Other:" in "Copy&Folders"
     (A-2) Junk
           Choice in "Other:" in "Junk Settings"
     This is same in both Tb 2.0 and Trunk(=Tb 3)  
 (B) Trash
    - Current(Tb 2)
      No UI.  mail.server.serverXX.trash_folder_name="Non-standard-trash-bin"
    - Trunk(Tb 3)
      - Check "When I delete a message/Move it to this folder"
        Expand selection list of folder
        Choose Non-standard-trash-bin
        (Note: Bug 427311 exists. Not resolved yet)  
      - When other than "When I delete a message/Move it to this folder",
        no access to standard Trash folder. So no creation request of Trash.

As seen in above, Tb's UI for special folder is "choice of folder", not "specify name for special folder in preference", although still "specify name for special folder in preference" internally when Trash.

Since "choice from existent folders", subscribe(already existent folder) or creation&subscribe(non existent folder) is required.
But in your case, and in many cases of "different from Tb's standard folder", I think "choice from existent folders" is usually sufficient, although Tb's UI is still slightly confusing and slightly hard to understand.

DUP of already done UI change on Trash folder choice?
(Reporter)

Comment 3

10 years ago
You are right. Sorry for spending your time.
I never realized that setting Sent, Drafts and Templates in Copy&Folders was making TB not create its special folders Sent, Drafts and Templates on the IMAP server.
Sorry again for the confusion.
Oh, sorry, INVALID was valid, because bug opener's request was mail...trash_folder_name like feature for Drafts etc. only. Sorry for my confusion.
(Reporter)

Comment 5

10 years ago
Choosing other folders in Copy&Folders indeed works, but then the localisation in the TB interface gets lost:
  - I set "OUTBOX" as the "Sent" folder => Name "OUTBOX" still remains in TB, but icon is ok.
You need to log in before you can comment on or make changes to this bug.