Crash in nsTextFrame::PaintAsciiText when deleting text in plain text compose

VERIFIED DUPLICATE of bug 42449

Status

()

P3
critical
VERIFIED DUPLICATE of bug 42449
19 years ago
17 years ago

People

(Reporter: lchiang, Assigned: kinmoz)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Crash in nsTextFrame::PaintAsciiText when deleting text in plain text compose

win32 2000-06-23-09-m17 build. 

1)  Reply to a plain text msg using plain text compose.  In the compose window, 
there is a scroll bar.
2)  Select text and press delete
3)  Crash occurs

Note:  I've tried to reproduce the crash, but unable to.  Since I have a 
talkback report with stack trace info, I'm logging this bug.  Perhaps there can 
be something that you may see which is obvious from my stack trace.

Talkback incident 12976849.

Stack trace:

   nsTextFrame::PaintAsciiText                                
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsTextFrame.cpp, line 2508]
   nsTextFrame::Paint                                        
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsTextFrame.cpp, line 1258]
   nsContainerFrame::PaintChild                                
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
211]
   nsBlockFrame::PaintChildren                               
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6464]
   nsBlockFrame::Paint                                       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6342]
   nsContainerFrame::PaintChild                                     
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
211]
   nsBlockFrame::PaintChildren                                     
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6464]
   nsBlockFrame::Paint                               
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6342]
   nsContainerFrame::PaintChild                                       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
211]
   nsBlockFrame::PaintChildren                                      
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6464]
   nsBlockFrame::Paint                                      
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 6342]
   nsContainerFrame::PaintChild                                  
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
211]
   nsContainerFrame::PaintChildren                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
155]
   nsHTMLContainerFrame::Paint                                
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLContainerFrame.cpp, line 
101]
   PresShell::Paint                                  
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3658]
   nsView::Paint                                         
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 280]
   nsViewManager2::RenderDisplayListElement                                          
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 816]
   nsViewManager2::RenderViews                                           
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 763]
   nsViewManager2::Refresh                                           
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 643]
   nsViewManager2::DispatchEvent                                              
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1303]
   HandleEvent                                          
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
   nsWindow::DispatchEvent                                        
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 564]
   nsWindow::DispatchWindowEvent                          
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 586]
   nsWindow::OnPaint                                          
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3488]
   nsWindow::ProcessMessage                                           
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2648]
   nsWindow::WindowProc                                      
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 830]
   USER32.dll + 0x131f (0x77e7131f)                                         
   USER32.dll + 0x1e9f (0x77e71e9f)                                          
   ntdll.dll + 0x1637b (0x77f7637b) 
   nsEditor::EndPlaceHolderTransaction                                            
[d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 1236]
   nsAutoPlaceHolderBatch::~nsAutoPlaceHolderBatch                                         
[d:\builds\seamonkey\mozilla\editor\base\nsEditorUtils.h]
   nsHTMLEditor::DeleteSelection                                    
[d:\builds\seamonkey\mozilla\editor\base\nsHTMLEditor.cpp, line 2348]
   nsHTMLEditorLog::DeleteSelection                                   
[d:\builds\seamonkey\mozilla\editor\base\nsHTMLEditorLog.cpp, line 160]
   nsTextEditorKeyListener::KeyPress                                            
[d:\builds\seamonkey\mozilla\editor\base\nsEditorEventListeners.cpp, line 209]
   nsEventListenerManager::HandleEvent                                         
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
1089]
   nsDocument::HandleDOMEvent                                            
[d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line 2994]
   nsGenericElement::HandleDOMEvent                                       
[d:\builds\seamonkey\mozilla\layout\base\src\nsGenericElement.cpp, line 1406]
   nsHTMLOListElement::HandleDOMEvent                                         
[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLOListElement.cpp, 
line 269]
   PresShell::HandleEventInternal                                             
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3901]
   PresShell::HandleEvent                                           
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3831]
   nsView::HandleEvent                                        
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 782]
   nsView::HandleEvent                                            
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 755]
   nsView::HandleEvent                                       
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 755]
   nsViewManager2::DispatchEvent                                        
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1389]
   HandleEvent                                           
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
   nsWindow::DispatchEvent                                          
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 564]
   nsWindow::DispatchWindowEvent                                          
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 581]
   nsWindow::DispatchKeyEvent                                
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2134] 
   nsWindow::OnKeyDown                                         
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2192]
   nsWindow::ProcessMessage                                         
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2755]
   nsWindow::WindowProc                                          
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 830]
   USER32.dll + 0x1268 (0x77e71268) 
   0x01530001

Comment 1

19 years ago
Bug 38762 and bug 37171 (of which the first one is a dup) are former crashes
in nsTextFrame::PaintAsciiText. Maybe it's worth having a look at pollmann's
patch in bug 38762.

Comment 2

19 years ago
Adding crash keyword to all open crashers.
Keywords: crash

Comment 3

19 years ago
upping severity..
Severity: major → critical
(Assignee)

Comment 4

19 years ago
I can't reproduce this in my 06/26/00 WinNt Mozilla debug build. lchiang, you 
still seeing this problem?
(Reporter)

Comment 5

19 years ago
kin - I was never able to reproduce the problem.  It just happened last Friday. 
Akkana suggested I file the bug anyway since I had a stack trace.  She commented 
to me that she didn't think PaintAsciiText was used anymore.
(Assignee)

Comment 6

19 years ago
I'm not exactly sure what to do with this bug if no one can reproduce it 
reliably.

I debugged a problem just like this before (bug #37264). It only occurs when the 
content data is out of sync with the frame data. If we can just nail down a 
reproduceable case, we can probably fix it the same way.
(Assignee)

Comment 7

19 years ago
I'll take this off beppe's plate for now.
Assignee: beppe → kin
Target Milestone: --- → M17
(Assignee)

Comment 8

19 years ago
Accepting bug.
Status: NEW → ASSIGNED

Comment 9

19 years ago
this is probably a dup of 42449


*** This bug has been marked as a duplicate of 42449 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 10

19 years ago
verified in 7/21 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.