Fx3 first run page is wider than firefox 3, so content is cropped and I get a horizontal scroll bar

VERIFIED INVALID

Status

www.mozilla.org
General
VERIFIED INVALID
10 years ago
6 years ago

People

(Reporter: Seth Spitzer, Unassigned)

Tracking

unspecified
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
first run page is wider than firefox 3, so content is cropped and I get a horizontal scroll bar

I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0 on windows xp.

see attached screen shot.
(Reporter)

Comment 1

10 years ago
Created attachment 323391 [details]
screen shot

Comment 2

10 years ago
Thanks Seth. Just for the sake of clarification here, this applies to the beta first run page, right?

FYI, we'll have a completely different (and more thoroughly tested) first run page in place when Firefox 3 launches.
(Reporter)

Comment 3

10 years ago
> Thanks Seth. Just for the sake of clarification here, this applies to the beta
> first run page, right?

not beta, but RC first run page:  http://en-us.www.mozilla.com/en-US/firefox/3.0/firstrun/

fwiw, I don't remember seeing this with the previous first run pages.
(Reporter)

Updated

10 years ago
Summary: first run page is wider than firefox 3, so content is cropped and I get a horizontal scroll bar → Fx3 RC1 first run page is wider than firefox 3, so content is cropped and I get a horizontal scroll bar
(In reply to comment #2)
> FYI, we'll have a completely different (and more thoroughly tested) first run
> page in place when Firefox 3 launches.
True, though the new first-run page is just about as wide as the RC first-run page.


(In reply to comment #3)
> fwiw, I don't remember seeing this with the previous first run pages.
The RC first run page is no wider than any of the Firefox 3 first-run pages.

Comment 5

10 years ago
> > FYI, we'll have a completely different (and more thoroughly tested) first run
> > page in place when Firefox 3 launches.
> True, though the new first-run page is just about as wide as the RC first-run
> page.
To be honest, I'm not too concerned if the RC first-run page isn't optimized for everyone (it works fine for me, btw) but it is a problem if the Firefox 3 first-run page (which, to be clear, looks completely different) doesn't work. 

Stephen Donner, is this a concern for you? Have you seen any instances where the Firefox 3 first-run page is getting cropped at the edges?

One last note: we optimized the new site for 1024x768 and above.

Updated

10 years ago
Target Milestone: --- → 3.0
In my testing, we can display at 961x804 without cropping any content -- I think this should be fine.
See also bug 420525, just as a point of reference from the client side; it looks like we open (on Windows, at least) our /firstrun/ page at ~ 960 x 1040, if my rudimentary "take a screenshot, make selection, and measure area" testing is "accurate".
mconnor / gavin: what dimensions is the /firstrun/ page/tab -- is that hardcoded?
This seems to refer to the beta/release-candidate pages. Can we close this?

Comment 11

10 years ago
Fine with me. I mainly just wanted to confirm that it doesn't affect any of the pages on the new site when it goes live.

If that's the case, then let's definitely close this one out.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 12

10 years ago
re-opening, I see this with the official fx 3 bits and fx 3 first run page.

here comes a screen shot.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: Fx3 RC1 first run page is wider than firefox 3, so content is cropped and I get a horizontal scroll bar → Fx3 first run page is wider than firefox 3, so content is cropped and I get a horizontal scroll bar
(Reporter)

Comment 13

10 years ago
Created attachment 325591 [details]
updated screen shot

I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Comment 14

10 years ago
Thanks Seth. What's your screen resolution? We optimized the new site for 1024x768, so if it's smaller than that then we have an easy explanation for this.
(Reporter)

Comment 15

10 years ago
my screen is 1680 x 1050.

but see gavin's comment (#9) about the first run window sizing logic.

I haven't confirmed it, but see this code snippet:

if (screen.availWidth >= 1600)
  defaultWidth = (screen.availWidth / 2) - 20; 

I think that might be setting my default width to 820 px.  (that seems right, if you look at the screen shot I've attached.)

gavin:  If sites are typically optimized for 1024, do you think that when the availWidth is >= 1600, we should make sure the defaultWidth is never smaller than 1024?

something like:

if (screen.availWidth >= 1600)
  defaultWidth = Math.max((screen.availWidth / 2) - 20, 1024);

if so, perhaps this should morph into a browser bug?
Bug 420525 was minused for fx3, but we should fix this for the point release.
Flags: blocking-firefox3.1?

Comment 17

10 years ago
(In reply to comment #16)
> Bug 420525 was minused for fx3, but we should fix this for the point release.
Agreed. And based on Seth's comments in #15, it sounds more like a browser bug than a design one. I could be wrong (it's happened before), but as far as I can tell the design of this page is functioning as intended. 

Agreed.  This isn't a mozilla.com bug, feel free to move elsewhere but with all the off topic comments I think it would be better to open a new bug.  closing this one.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → INVALID
Flags: blocking-firefox3.1?
(Reporter)

Comment 19

9 years ago
I've started a browser bug on fixing the first run window sizing logic, see bug #476680, as this is still an issue with 3.1
Status: RESOLVED → VERIFIED
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.