Add-ons dialog no longer contains a restart button after installing an XPI file. (Regression from 2.x)

RESOLVED DUPLICATE of bug 434551

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED DUPLICATE of bug 434551
10 years ago
10 years ago

People

(Reporter: Troy Wright, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

After installing an XPI file, Firefox 2.x would provide a restart button along with instructions that the browser needed to restart.  In Firefox 3 RC1, the dialog just says "Install Completed Successfully" although the plugin is not available until after a restart.


Reproducible: Always

Steps to Reproduce:
1.Make sure the 'Move Media Player' plugin is not installed.
2.With Firefox RC1, go to ABC.com
3.Watch any full length episode
4. You will be asked to install the Move Media player
5. After the XPI install, you will see the success dialog without the prompt
6. ABC and other sites are counting on the restart button to provide the user with some instruction and allow the user to easily return to the current page. 
Actual Results:  
I was presented with a dialog stating the install was successful even though a restart of Firefox is still needed.

Expected Results:  
A dialog containing a restart button along with instructions that the install will be completed after Firefox restarts. (Expect at least the same functionality as Firefox 2.x)
Component: General → Extension/Theme Manager
QA Contact: general → extension.manager
I suspect this is bug 436207 but cannot verify since I am not in the US. Is the xpi that they offer for download available anywhere?
Checked xpi sent by email. It uses the deprecated plugin em:type.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 434551
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.