Closed Bug 437050 Opened 12 years ago Closed 12 years ago

"Could not connect to server" dialog cannot be suppressed

Categories

(Thunderbird :: Mail Window Front End, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 123440

People

(Reporter: wild, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: version 2.0.0.14 (20080421)

When a network connection is not available (e.g. when moving from one place to another with a laptop or with an intermittent internet connection) an alert dialog appears that must be acknowledged before Thunderbird becomes responsive. If there are 5 email accounts, 5 separate dialogs need to be dismissed in rapid succession to bring Thunderbird to a useable state.

This error should appear as a non-intrusive, non-workflow-interrupting status bar notification, or there should be an option to select this behaviour.

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird
2. Disconnect from Internet
3. Attempt to check email (or wait for a scheduled auto-check)
Actual Results:  
Dialog appears and must be dismissed before app can be used

Expected Results:  
Status bar notification allowing information to be conveyed (possibly with error icon) without interrupting workflow.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 123440
You need to log in before you can comment on or make changes to this bug.