Closed Bug 437056 Opened 13 years ago Closed 13 years ago

run a message filter on a folder - "choose this folder" option missing, can't run on folders with subfolders

Categories

(Thunderbird :: Mail Window Front End, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0a3

People

(Reporter: info, Assigned: jminta)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a1pre) Gecko/2008053002 Minefield/3.1a1pre
Build Identifier: 3.0a2pre (2008060203)

On moving a message you can choose 'Move here' as an option to move a message to a folder that has subfolders. When running a message filter this isn't possible.

Reproducible: Always

Steps to Reproduce:
1. Create a mailfolder with subfolders
2. Create a message filter
3. Try to run the filter on the folder that has subfolders
Ah yes:( 
The "choose this folder" option is missing. 

Regression window 2008-05-31 2008-06-01:
<http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=ThunderbirdTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-05-30+03%3A00%3A00&maxdate=2008-05-31+03%3A00%3A00&cvsroot=%2Fcvsroot>

I would assume this is due to bug 435804.
Blocks: 435804
Component: General → Mail Window Front End
Keywords: regression
OS: Linux → All
QA Contact: general → front-end
Hardware: PC → All
Summary: It's impossible to run a message filter on a folder that has subfolders → run a message filter on a folder - "choose this folder" option missing, so can't run on folders with subfolders
Version: unspecified → Trunk
It should just need "showFileHereLabel" and "fileHereLabel" attributes on the menupopup.  I'll try to get to this later tonight.
Attached patch patch v1 (obsolete) — Splinter Review
This patch adds the attributes, as I mentioned.  It also fixes a problem where icons weren't showing up for the folders in the menu.
Assignee: nobody → jminta
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #324194 - Flags: review?(mkmelin+mozilla)
Comment on attachment 324194 [details] [diff] [review]
patch v1

Looks good! r=mkmelin
Attachment #324194 - Flags: review?(mkmelin+mozilla) → review+
Duplicate of this bug: 437907
Summary: run a message filter on a folder - "choose this folder" option missing, so can't run on folders with subfolders → run a message filter on a folder - "choose this folder" option missing, can't run on folders with subfolders
Comment on attachment 324194 [details] [diff] [review]
patch v1

I noticed this is only part of the fix. It does add back the "choose this folder" - but the actual selecting of a subfolder does nothing.
Attachment #324194 - Flags: review+ → review-
Flags: blocking-thunderbird3.0a2?
Flags: blocking-thunderbird3+
I can confirm Magnuses words. The option is there, but you cannot select any sub-folder. After making selection (clicking on folder) it just jump back on "INBOX".

My version is: version 3.0a2pre (2008063003) (no other patches added).
Still not working!

version 3.0a2pre (2008070703)
Note that the imap trash folder menu is also affected by this - subfolders can't be selected. Think they use (~) the same code.
Another place that looks like the same problem is when you try and select a folder to run filters on. (not just the destination). 

In particular if your inbox has subfolders (mine do), there seem to be problems creating or editing filters so they apply to the inbox. 
Flags: blocking-thunderbird3.0a2? → blocking-thunderbird3.0b1?
Whiteboard: [needs updated patch]
we should fix this for b1
Flags: blocking-thunderbird3.0b1? → blocking-thunderbird3.0b1+
Confirming Mitra's words. The "Run selected filters on:" in "Message Filters" still handles folder-choosing the old way, doing nothing at all (impossible to choose any other folder than "Inbox"). (Shredder/3.0b1pre)
Switching for b1 flags to target milestones, to avoid flag churn.
Target Milestone: --- → Thunderbird 3.0b1
Assignee: jminta → nobody
Status: ASSIGNED → NEW
Priority: -- → P3
jminta, can you look at this? My guess is that this might be fallout from some previous changes...It's on our b1 blocking list.
Attached patch patch v2Splinter Review
Adds the attributes, and watches for selection.

This is the general problem with structuring menus like this (as opposed to the flat structure the binding can also do), but that's a battle for another day.
Assignee: nobody → jminta
Attachment #324194 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #337074 - Flags: review?(mkmelin+mozilla)
Whiteboard: [needs updated patch] → [needs review mkmelin]
Attachment #337074 - Flags: review?(mkmelin+mozilla) → review+
Comment on attachment 337074 [details] [diff] [review]
patch v2

Yep, this seems to work, thx! r=mkmelin
3.0b1 flag is going away in favour of 3.0 flag and milestone combination.
Flags: blocking-thunderbird3.0b1+
Whiteboard: [needs review mkmelin] → [ready to land]
Pushed "patch v2" as 361:d6628cc24bc5
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [ready to land]
You need to log in before you can comment on or make changes to this bug.