Status

()

P3
normal
VERIFIED INVALID
19 years ago
18 years ago

People

(Reporter: busterb, Assigned: harishd)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
When several tables are nested withing a table cell, the columns within the
nested tables are not rendered properly. Code like the following:
<table>
<tr>
<td>Hello</td>
<td><table>
	<tr>
		<td>Bye</td>
	</tr>
</td>
</tr>
</table>

Hello and Bye appear in the same column. Using 6/23/2000 build

Comment 1

19 years ago
Your given code is missing a </table> tag, but in any case, I cannot get it to
be printed into the same column as you described with build 2000062311.  I did,
however, see that the above URL is not rendered the same way as in Netscape
4.73.  I'll have to read the HTML source to see what's going on.

Comment 2

19 years ago
I don't know enough about HTML to know whether this is a bug or not, but I do
know that if I take the HTML file and erase the first line:

  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN">

Then the page renders in exactly the same way as Netscape 4.73.

Comment 3

19 years ago
Harish, you can decide if this is a bug or not.
Assignee: karnaze → harishd
(Reporter)

Comment 4

19 years ago
There was a missing quote in
  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"> - I was making a test case
and I changed it to 
  <!"DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"> - same problem with
Mozilla, and Netscape 4.73 still renders fine.

The page renders under Mozilla, however with <!"DOCTYPE HTML PUBLIC "-//W3C//DTD
HTML 3.2//EN">. I have found no missing table tags, and I don't know what
changed with tables in HTML 4.01.
(Assignee)

Comment 5

19 years ago
I don't see any problem ( 06/22/00 build ) with the snippet. But, in the above 
URL, menu on the left hand side, looks whacky.  I think this is something to do 
with IMG inside TABLE.

CCing Chrish.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 6

19 years ago
The problem is exactly the wacky menu.
(Assignee)

Comment 7

19 years ago
On June 26th build everthing looks fine. Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 8

19 years ago
I don't see any difference in 2000062610.  The menu is still not displayed
properly.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 9

19 years ago
Created attachment 10683 [details]
Simplified test - font tags are the problem
(Reporter)

Comment 10

19 years ago
When the HTML 4.01 or 4.0 DTD is specified under Mozilla 2000062610, if a nested
table is placed between font tags in the outer table's cell, the nested table or
tables are not rendered. The attached code illustrates this..just uncomment the
font tags!
(Reporter)

Comment 11

19 years ago
Created attachment 10684 [details]
An even simpler, perhaps cuter example - elvis can render this one
(Assignee)

Comment 12

19 years ago
Will look into it. Thanx for the testcase.
Status: REOPENED → ASSIGNED
Target Milestone: --- → M18
(Assignee)

Comment 13

19 years ago
Okay, I see the mistake.  The above URL and the testcases are using STRICT 
DOCTYPE,i.e., " <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"> ", but failed 
to follow the spec. 

Per spec. FONT cannot contain TABLE ( STRICT DTD follows this ). Therefore, in 
the testcase, the TABLE after FONT got thrown away [ Note: it's upto the user 
agent to handle malformedness ;-) ].

Changing the DOCTYPE ( < 4.0 ) should fix the problem.

Marking this bug INVALID.  
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → INVALID

Comment 14

18 years ago
INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.