[10.4] Shockwave plugin broken

VERIFIED WORKSFORME

Status

Plugins Graveyard
Shockwave (Adobe)
--
major
VERIFIED WORKSFORME
10 years ago
2 years ago

People

(Reporter: Tom X, Unassigned)

Tracking

({shockwave})

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en; rv:1.9pre) Gecko/2008052500 Camino/2.0a1pre (like Firefox/3.0pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en; rv:1.9pre) Gecko/2008052500 Camino/2.0a1pre (like Firefox/3.0pre)

Shockwave 10.1.1r16 doesn't work in Camino May 25, 2008.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

10 years ago
Flags: camino1.6.2+
Version: unspecified → Trunk
(Reporter)

Comment 1

10 years ago
Shockwave 10.1.1r16 doesn't work in Camino May 25, 2008.
Keywords: shockwave
Whiteboard: Shockwave

Comment 2

10 years ago
You need the latest Shockwave version (v11), if you are using nightly builds.

http://www.adobe.com/shockwave/download/alternates/#sp
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> You need the latest Shockwave version (v11), if you are using nightly builds.
> 
> http://www.adobe.com/shockwave/download/alternates/#sp
> 
Shockwave version (v11) doesn't work on my machine.
Tiger 10.4.11 PPC

Tom

Comment 4

10 years ago
Hmm. Bug 426121 removed a Shockwave rsrc workaround from trunk builds, under the understanding that Shockwave 11 ran on both Intel and PPC, 10.4+
See also:
http://www.adobe.com/products/shockwaveplayer/productinfo/systemreqs/

Does it mean that Shockwave 11 doesn't install on 10.4 ppc, or that it doesn't run ?
The plugin I have installed (on 10.5 Intel) claims to be an universal binary.
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> Hmm. Bug 426121 removed a Shockwave rsrc workaround from trunk builds, under
> the understanding that Shockwave 11 ran on both Intel and PPC, 10.4+
> See also:
> http://www.adobe.com/products/shockwaveplayer/productinfo/systemreqs/
> 
> Does it mean that Shockwave 11 doesn't install on 10.4 ppc, or that it doesn't
> run ?
> The plugin I have installed (on 10.5 Intel) claims to be an universal binary.
> 
Shockwave 11 installs just fine - it just doesn't run.
I'm not the only one that this applies too.

Tom
Please don't set any flags; they're reserved for developer use (and this doesn't affect 1.6.x, anyway).

Shockwave 10 is no longer supported on the trunk, as noted in comment 4.  If Shockwave 11 doesn't work on PPC or 10.4, that's a serious Adobe bug.
Flags: camino1.6.2+
Whiteboard: Shockwave

Comment 7

10 years ago
(In reply to comment #5)
> Shockwave 11 installs just fine - it just doesn't run.

What do you mean by "doesn't run"? What specifically happens when you visit http://www.adobe.com/shockwave/welcome/ with it installed? 

> I'm not the only one that this applies too.

Could you elaborate on this? Who are these other people, what are their machine configurations, how are they testing, and what specific result are they seeing?
(Reporter)

Comment 8

10 years ago
> Smokey Ardisson wrote: Please don't set any flags... blah blah blah.
No problem, this is my final post... here.

> Stuart Morgan wrote: Could you elaborate on this? Who are these other people, what are their machine configurations

These people are on line friends (easily a hundred of them) because of Jan. 25, 2006 (and other post as well).
<http://www.macintouch.com/ReaderReports/quicktime7_0_4/topic3905.html>
The OS is always Tiger - most are PPC - Intels, only about 4% or so.

> Stuart Morgan wrote: how are they testing, and what specific result are they seeing?
They test by surfing to a shockwave site and all they see the broken icon for shockwave.

Good bye,

Tom X

Comment 9

10 years ago
On 10.5.3/PPC, after installing Shockwave from the "slim installer" at

http://fpdownload.macromedia.com/get/shockwave/default/english/macosx/latest/Shockwave_Installer_Slim.dmg

and then visiting

http://www.adobe.com/shockwave/welcome/

I see a Shockwave animation that works great and displays the version number "11.0r430" at the completion of the animation.

about:plugins says:

"Shockwave for Director

File name: DirectorShockwave.plugin
Adobe Shockwave for Director Netscape plug-in, version 11.0.0"

Comment 8 seems to indicate this is 10.4-only, so I'm marking it as such and confirming it for tracking purposes (and kicking to Core:Plugins, since it won't be only Camino users who are affected).
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Plug-ins → Plug-ins
Ever confirmed: true
Product: Camino → Core
QA Contact: plugins → plugins
Hardware: Macintosh → All
Summary: Shockwave 10.1.1r16 doesn't work in Camino May 25, 2008. → [10.4] Shockwave plugin broken
Version: Trunk → unspecified

Comment 10

10 years ago
(In reply to comment #8)

> These people are on line friends (easily a hundred of them) because of Jan. 25,
> 2006 (and other post as well).
> <http://www.macintouch.com/ReaderReports/quicktime7_0_4/topic3905.html>

I see absolutely nothing anywhere in that entire document discussing Shockwave. That seems to be about DiskWarrior; perhaps you posted the wrong link?

Comment 11

10 years ago
Shockwave 11 works for me on 10.4.11, it worked for Smokey when he tested a while back on 10.4, and I can't find any discussion of widespread failures on 10.4 online in a quick search, so I'm closing this WFM (especially since the reporter has indicated that he is unwilling to provide any further follow-up information to try to narrow down a failure condition).
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 12

10 years ago
Yeah, I can't find anything either, and I didn't mean to confirm this when I moved it.

Comment 13

10 years ago
Not that it has anything to do with Firefox, but Opera doesn't run shockwave for me at all. It stops at the adobe logo that you see while the plugin loads. Doesn't opera use the Netscape shockwave plugin? Though I don't see Operas name on the requirements link above.

Comment 14

10 years ago
Also, I am referring to Shockwave 11, not 10.4 as the title states.

Comment 15

10 years ago
(In reply to comment #13)
> Not that it has anything to do with Firefox, but Opera doesn't run shockwave
> for me at all.

Bugzilla is not a technical support forum, and it is most certainly not a forum for discussing problems with Opera (or any other browser not based on the Mozilla code). You should use Opera's support forum for this issue, and please read 

https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

before commenting further.
Status: RESOLVED → VERIFIED

Comment 16

10 years ago
(In reply to comment #15)
> (In reply to comment #13)
> > Not that it has anything to do with Firefox, but Opera doesn't run shockwave
> > for me at all.
> 
> Bugzilla is not a technical support forum, and it is most certainly not a forum
> for discussing problems with Opera (or any other browser not based on the
> Mozilla code). You should use Opera's support forum for this issue, and please
> read 
> 
> https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
> 
> before commenting further.
> 

I'm just pointing out that Opera has the problems with the shockwave plugin for me, which I think is the same plugin as firefox was using. 

Comment 17

10 years ago
(In reply to comment #16)
> I'm just pointing out that Opera has the problems with the shockwave plugin for
> me, which I think is the same plugin as firefox was using. 

As you said yourself in comment 13, "not that it has anything to do with Firefox".

I'm just pointing out that anyone working in Bugzilla is EXTREMELY unlikely to care what is or isn't broken in Opera (or any other browser not based on the Gecko engine). Please refrain from commenting further unless you have something constructive to say that is relevant to the functionality of Shockwave in Gecko-based browsers on the Mac.

Is that clear enough for you?

Updated

8 years ago
Component: Plug-ins → Shockwave (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-shockwave
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.