quick search cleared after switching to/from lightning

RESOLVED WORKSFORME

Status

Thunderbird
Search
--
minor
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: abrown, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5
Build Identifier: version 2.0.0.14 (20080505)

The quick search widget contents are kept but the search itself is cleared after switching to/from lightning.  Eg, quick search for something in your inbox then switch to the lightning calendar display and switch back to mail.  The search results will be cleared but the search text itself will remain in the widget.

I think this is a thunderbird bug rather than a lightning bug since it occurs after leaving the calendar component.

Maybe related to bug 392636?

Reproducible: Always

Steps to Reproduce:
1.enter text in quick search widget
2.wait for search results to be displayed
3.switch to lightning
4.switch back to mail
Actual Results:  
Widget contains the search text but message display shows all messages (not search results).

Expected Results:  
Either show all messages and clear the widget or keep the widget and show search results.

Using Lightning v0.8

Comment 1

10 years ago
testing it on vista: (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.14)

Lightning/0.8 Thunderbird/2.0.0.14 - Build ID: 2008042104
It's ok here, qsearch txt and results stick.

Lightning/0.9pre Thunderbird/2.0.0.14 - Build ID: 2008042104
It's ok here, qsearch txt and results stick.

not happening here on win ...
(Reporter)

Comment 2

10 years ago
Also occurs on my XP pro machine with TB version 2.0.0.14 (20080421) and lightning 0.8

Comment 3

9 years ago
bug 449619 is another lightning+quick search issue
We redesigned the way quick-search box was coded in june  - the code is completely new. abrown do you still have the issue with Thunderbird 3.0b4 ? If you do what do you see in Tools -> Error console ?
(Reporter)

Comment 5

9 years ago
I don't have 3.0 beta.... if there's some easy way to try the beta in Ubuntu?  It still fails for me with lightning 0.9 and TB 2.0.0.23
(In reply to comment #5)
> I don't have 3.0 beta.... if there's some easy way to try the beta in Ubuntu? 
> It still fails for me with lightning 0.9 and TB 2.0.0.23

Yes it's in PPA -> https://edge.launchpad.net/~ubuntu-mozilla-daily/+archive/ppa
Abrown do you still see the issue ?
Component: Mail Window Front End → Search
QA Contact: front-end → search
Whiteboard: [closeme 2011-09-15]
(Reporter)

Comment 8

7 years ago
seems good in 3.1.10.  Can't say that I noticed when it started working....
Hardware: x86 → x86_64
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2011-09-15]
You need to log in before you can comment on or make changes to this bug.