[Fx3] Update request even if an update was already downloaded

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m), Unassigned)

Tracking

({ue})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008060306 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008060306 Minefield/3.0pre

After a while I downloaded an update for Fx3, but _not_ restarted Fx and applied it, Fx re-asked me to download the update

Reproducible: Always

Steps to Reproduce:
1. If you have not, install the latest Fx3 trunk
2. Wait for an update, download it but not restart Fx
3. Wait some hours
Actual Results:  
After a while, Fx3 re-ask you to download the update another time. If you restart Fx applying the update and check for updates, Fx tells you it is up to date.


Additional info:

I set app.update.interval, app.update.nagTimer.restart and app.update.promptWaitTime to 7200 (see Bug 427369)
Are you sure it wasn't prompting you to install the already downloaded update ? A 2 hour nagTimer could do that.
Keywords: ue
Version: unspecified → Trunk
No, it was a download request. Anyway I tested this problem setting very low values to app.update.interval, app.update.nagTimer.restart and
app.update.promptWaitTime, downloading a new update and waiting. The problem didn't show up again. I change the resolution to WORKSFORME for now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Nothing, it re-happened today. I downloaded 2008061305 without restarting, after a while (I think 2 hours, because of mu options) the download request reopened. I'm sure it was the download request, and not the restart request. When I applied the updated and checked for other updates, Fx didn't find nothing.

I can't reproduce the bug. What can I do to track it?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
I noticed that it doesn't happen if the update was downloaded in automatic. It happens only when Fx asks me if I want to download the update.

I have "Automatically download and install" and "Warn me if this will disable any add-ons" checked.
The default settings seem to be
  app.update.interval  86400
  app.update.nagTimer.restart  86400
  app.update.promptWaitTime  43200
and you're setting them all to the same value of 7200. 

It would be useful to know if the bug still happens if you set app.update.promptWaitTime to a smaller value than 7200, or if it's just related to small values for all these prefs.
I should test it in a blank profile, yes. I don't think anyway I can leave my PC on for 24 hours...
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit

Comment 7

9 years ago
Lucas, what results from your blank profile test?
http://kb.mozillazine.org/Updates_reported_when_running_newest_version
Whiteboard: closeme 2009-06-15
Currently I can't test it.
This has close me status of 6-15, but there's still discussion going on about this. Lucas, when can you find a cycle to test this in a new profile? 


Side note, changing the closeme status to a month from now.
Whiteboard: closeme 2009-06-15 → closeme 2009-07-31
@Desai: I don't know when I can test it. I close it as WFM, I'll reopen it if I'll do the test.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → WORKSFORME
Whiteboard: closeme 2009-07-31
You need to log in before you can comment on or make changes to this bug.