Seamonkey with TBE2 crashes (Tabbrowser extension)

RESOLVED INCOMPLETE

Status

SeaMonkey
General
--
critical
RESOLVED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: Yevgeny Kosarzhevsky, Unassigned)

Tracking

({crash, stackwanted})

SeaMonkey 1.1 Branch
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.8.1.13) Gecko/20080402 SeaMonkey/1.1.9
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.8.1.13) Gecko/20080402 SeaMonkey/1.1.9

crash occurs if I am trying to open search result

Reproducible: Always

Steps to Reproduce:
1. Create fresh profile under fresh browser installation
2. Install Tabbrowser extension from http://piro.sakura.ne.jp/xul/xpi/confirm.cgi?tabextensions_en.xpi to profile directory. Press 'ok' on each next question of TBE installer and 'cancel' to the question about Japanese language pack
3. Restart seamonkey
4. Upon startup choose TBE preset in 'TBE preferences' window which should open automatically.
5. Type goosh.org in browser's address line.
6. Do a search of any word, let's say 'seamonkey'
7. After results displayed in google shell, press '1' and enter
Actual Results:  
Seamonkey crashes

Expected Results:  
seamonkey won't crash
(Reporter)

Updated

10 years ago
Keywords: crash
Version: unspecified → SeaMonkey 1.1 Branch

Comment 1

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9

It is crashes In Windows Vista.

Talkback isn't run.
(Reporter)

Comment 2

10 years ago
similar crash occurs when using gmail.com website, but it is hard to remember how to reproduce it - actually I suspect it is crashing when new window opens using some ajax code.
(Reporter)

Comment 3

10 years ago
bug still exists in Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.8.1.15) Gecko/20080629 SeaMonkey/1.1.10

Comment 4

9 years ago
http://piro.sakura.ne.jp/xul/tabextensions/old_index.html.en

"Tabbrowser Extensions 2 works on Firefox 1.5, not Firefox 2. In Firefox 2 or later, you should use "TBE3", a subset of TBE2."

SeaMonkey 1.1 corresponds to Firefox 2.0. Try installing TBE3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

9 years ago
Yes, but the whole application should not crash because of wrong XUL application. The bug itself not regarding of an extension misuse but regarding a crash. TBE2 extension just showing how to reproduce a crash.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 6

9 years ago
Linux x64 isn't officially supported.
Can you reproduce with an official Linux x86_32 build?
Try running under the debugger to get a stack trace. On linux start the seamonkey shell script with the -debug switch (or is it --debug ?)
(Reporter)

Comment 7

9 years ago
I confirm it on 32 bit build:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb71e96b0 (LWP 8490)]
0xb61b68db in ?? () from /usr/local/seamonkey/components/libgklayout.so
(gdb) bt
#0  0xb61b68db in ?? () from /usr/local/seamonkey/components/libgklayout.so
#1  0xbfec3af4 in ?? ()
#2  0xb7e2e1de in JS_EndRequest () from /usr/local/seamonkey/libmozjs.so
#3  0xb61b65b4 in ?? () from /usr/local/seamonkey/components/libgklayout.so
#4  0x00000000 in ?? ()

Comment 8

9 years ago
> /usr/local/seamonkey/components/libgklayout.so
This is core gecko code. Unfortunately the 1.8.1 branch is only considering critical security and stability fixes. So to get this fixed you'll need to do at least two things:

1. submit a patch.
2. convince the drivers that this is a critical patch worth the risk.

Unfortunately this is a rare crash triggered by an obscure and obsolete extension which the author doesn't support.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

9 years ago
note that if you want to chase this, you either need to build --enable-debugger-info-modules/--enable-debug or you need to get enough pieces (including a working libcurl+cacerts) in a 32bit world to get the crash reporter to work w/ an official build.

the functions in the stack trace aren't correct because your debugger didn't have symbols

Comment 10

9 years ago
 Yevgeny can you reproduce using version 2?
Keywords: stackwanted

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago7 years ago
Resolution: --- → INCOMPLETE
Summary: Seamonkey with TBE2 crashes → Seamonkey with TBE2 crashes (Tabbrowser extension)
You need to log in before you can comment on or make changes to this bug.