Up arrow not working in menus; down arrow no longer working as expected

RESOLVED FIXED

Status

()

P3
normal
RESOLVED FIXED
19 years ago
11 years ago

People

(Reporter: bugzilla, Assigned: hyatt)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

(Reporter)

Description

19 years ago
Build ID: 2000062408

Someone else also saw this on Linux.  Highlight (put the mouse over) an item in 
a menu, and press the up arrow.  Nothing happens.

Comment 1

19 years ago
Linux, build ID 2000062408

Down arrow works fine, up arrow does nothing.
heh, yeah i see this today on linux [2000.06.26.08 commercial]... in fact, i
also see on winnt [friday's bits, 2000.06.2308] and in the context menus on Mac
[also using 2000.06.23.08]. over to xp menus...
Assignee: don → pinkerton
Component: Keyboard Navigation → XP Toolkit/Widgets: Menus
QA Contact: sairuh → jrgm
whups, slightly misleading phrasing above: meant to confirm blake's observation
in win32... also, since this xp, gotta change the platform info... :-)
OS: Windows 98 → All
Hardware: PC → All
works for me, both win2k and linux
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

19 years ago
reopening...sairuh saw it xp, peter saw it in 6/24 linux, I still see it in 
62608 win98, someone on IRC just saw it with 62508 win2k, doron sees it with 
today's win32 build [win98], and asa sees it in today's win32 and mac builds.

[looks like you're in the minority here pink :p ]
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I talked to hyatt, and the suggestion is this:

add a flag to nsBoxFrame::GetInsertionPoint() which makes it recursive and 
repeatedly drills down to get the insertion point of the returned child until it 
doesn't find one. once this is done, nsMenuBar and nsMenuPopupFrame need to pass 
PR_TRUE for this param. The new menus have a insetion point deeper than they used 
to (now that it's in xbl). 

Why did I push this to you? Well, this requires adding a method to nsIBox and 
touching about 15 files. You break it, you buy it ;)
Assignee: pinkerton → evaughan
Status: REOPENED → NEW
Keywords: nsbeta2, regression
*** Bug 43731 has been marked as a duplicate of this bug. ***
*** Bug 43733 has been marked as a duplicate of this bug. ***
modified summary to reflect bug 43731 and bug 43733.
Summary: Up arrow not working in menus → Up arrow not working in menus; down arrow no longer working as expected

Comment 10

19 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]

Comment 11

19 years ago
Sorry, removing [nsbeta2+], replacing with [nsbeta2-] (keyboard functionality 
does not seem to be a beta2 blocker), adding nsbeta3 keyword.
Keywords: nsbeta3
Whiteboard: [nsbeta2+] → [nsbeta2-]
Target Milestone: --- → M20
*** Bug 45416 has been marked as a duplicate of this bug. ***
adding alec to cc list

Comment 14

19 years ago
I know people are going to hate me for this, but I'd like one reevaluation
because menus are used ALL over the product, and this is just embarassing.
Netscape WILL get slammed in the press for this one. How are people going to
take us seriously if we can't get menus right? 

This is more than just up/down arrows not working - ALL keyboard accelerators on
ALL menus are broken.

(removing nsbeta2- for a reevaluation)
Whiteboard: [nsbeta2-]
(Reporter)

Comment 15

19 years ago
The accelerator key issue is bug 44270

Comment 16

19 years ago
blake just brought it to my attention that bug 44270 is the accelerator key bug.
Copying my rant to that bug, and returning the nsbeta2- status.
Whiteboard: [nsbeta2-]

Comment 17

19 years ago
I have no idea.
Assignee: evaughan → hyatt
(Assignee)

Comment 18

19 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Updated

11 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.