zero-length events/tasks overlaps in calendar view

VERIFIED FIXED in 0.9

Status

Calendar
Calendar Views
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Andreas Treumann, Assigned: Berend Cornelius)

Tracking

unspecified
Bug Flags:
blocking-calendar0.9 +

Details

(Whiteboard: [probably-fixed-by-437412])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 323824 [details]
screenshot

STEPS TO REPRODUCE:
===================

- create an event start time 8.00 AM , end time 8:00 AM
- create an second event or task with the same start time/end time
- check the calendar views

RESULT:
=======

- the events/tasks overlapps (see attached screenshot)

EXPECTED RESULT:
================

- both events/task should be visible

REPRODUCIBLE:
=============

- always
Flags: wanted-calendar0.9?

Comment 1

10 years ago
Andres, how is the regression? There was a fix for events with very short periods a couple of days ago, does this happen before or after the fix.
(Reporter)

Comment 2

10 years ago
Not directly a regression, because before bug 387402 was checked in zero-lenght events overlapps too. But this wasn't so visible.
My guess to the cause of this bug:
the patch for bug 387402 did change the code that draws the boxes, but not the 'war on boxes' code, the code that puts conflicting events in different columns. That code only deals with times, not with pixels, and the minimum height code does not do time, only pixels. Somewhere, a conversion between the two should be added.

Updated

10 years ago
Flags: wanted-calendar0.9? → wanted-calendar0.9+
Summary: zero-lenght events/tasks overlapps in calendar view → zero-length events/tasks overlaps in calendar view

Updated

10 years ago
Flags: blocking-calendar0.9?

Comment 4

10 years ago
Berend, could you please have a look at this one?
Flags: blocking-calendar0.9? → blocking-calendar0.9+
Assignee: nobody → Berend.Cornelius

Updated

9 years ago
Whiteboard: [needs patch]
I've tested this with the patch for bug 437412 and everything worked fine.
Flags: wanted-calendar0.9+
Whiteboard: [needs patch] → [probably-fixed-by-437412]

Updated

9 years ago
Depends on: 437412
(Assignee)

Comment 6

9 years ago
As I and Andreas tested this is fixed with the check in of bug 437412
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
(Reporter)

Comment 7

9 years ago
Checked in lightning 2008082620 and Sunbird 20080826 -> VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.