Dragged images corrupted

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: t_edwards, Unassigned)

Tracking

1.9.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120713])

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Images that are dragged from a web page onto a folder or onto the desktop are corrupted. It's better to view the attached results than listen to me trying to explain how!

Reproducible: Always

Steps to Reproduce:
1. Drag chosen image to a location
2. Save chosen image to a location
3. Compare
Actual Results:  
Dragged image is completely corrupt.

Expected Results:  
Dragged image is not corrupt, and is identical to saved image.
(Reporter)

Comment 1

10 years ago
Created attachment 323852 [details]
Three pairs of images showing the corruption
Could you unzip it and attatch a picture of the three images side-by-side so that we don't have to download it.
(Reporter)

Comment 3

10 years ago
I would have, but I'm a bit worried that the server will choke on the corrupt ones. Is unzipping a file that much to ask anyway?
Created attachment 324009 [details]
Side-by-side

Can't reproduce, but heres the pictures all together. theyre just collected into one png but the quake-lake one won't even open on my system.

Can you provide a link maybe to the pics you tried this on?
(Reporter)

Comment 5

10 years ago
I can't find the 'art' image again, but here's the other two:

http://news.bbc.co.uk/2/hi/asia-pacific/7437354.stm

It doesn't seem to matter where the images come from, though.
Comment on attachment 324009 [details]
Side-by-side

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Hmm... was able to reproduce reliably with the combined pic.

(i.e. drag gets corrupted entirely and i can't see anything, while save works perfectly)
(Reporter)

Comment 7

10 years ago
I just noticed that the filesize of images, in Element Properties, is always "Unknown (not cached)".
(Reporter)

Comment 8

10 years ago
This appears to have been fixed in 3.0 final. Can you confirm, Natch?
Nope can't reproduce atm, except for the combined pic of your corrupted images (although that _may_ be because it has corrupted images in it, dunno). Otherwise, with any other image I tried it works just fine.

--> WORKSFORME
(Reporter)

Comment 10

10 years ago
I just found an image that exhibits this problem in Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1:

http://www.jstor.org/pss/1318873

Perhaps of relevance is the server's behaviour if you request the image directly:

http://www.jstor.org/action/showArticleImage?image=images%2Fpages%2Fdtc.24.tif.gif&doi=10.2307%2F1318873
> http://www.jstor.org/pss/1318873

this is WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080906062345 Minefield/3.1b1pre ID:20080906062345 + Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 ID:2008070208(In reply to comment #10). maybe it's Vista relevant.
Version: unspecified → 3.0 Branch
(Reporter)

Comment 12

10 years ago
Nope, I'm still getting it with XP too.
Duplicate of this bug: 466719
Component: Shell Integration → Drag and Drop
Keywords: qawanted
Product: Firefox → Core
QA Contact: shell.integration → drag-drop
Version: 3.0 Branch → 1.9.0 Branch

Comment 14

7 years ago
I am still getting this bug with various images on Windows 7 64 with Firefox 4 and 5.
(Reporter)

Comment 15

7 years ago
I can't repro on Fx5 and Windows 7 x64.

Comment 16

7 years ago
Could you attempt it with these images here:
http://interfacelift.com/wallpaper/De8dadd5/02625_thereignofthestars_1440x900.jpg
or
http://v.cdn.cad-comic.com/comics/cad-20110629-f5abc.png

I think it may have something to do with the length of the images filename as it never happens with shorter filenames.
(Reporter)

Comment 17

7 years ago
I get a 0KB file when I try dragging the comic, not a corrupt one. I uploaded the file to <http://steamreview.org/external/cad-20110629-f5abc.png> and it works fine from there, so it can't be the filename. The wallpaper doesn't exist any longer.

Here are the response headers from the two comic downloads. Two things stand out to me: that the official site is using GZIP, and that it does not specify Content-Length.

cad-comic.com:

Cache-Control:max-age
Connection:keep-alive
Content-Encoding:gzip
Content-Type:image/png
Date:Fri, 01 Jul 2011 21:51:59 GMT
Etag:"16bd02d31fe9fa8e053a23bfdf16cc50"
Expires:Fri, 29 Jun 2012 03:11:41 GMT
Keep-Alive:timeout=15
Last-Modified:Thu, 30 Jun 2011 03:11:34 GMT
Server:azeroth
Transfer-Encoding:chunked
Vary:Accept-Encoding
X-Cache:HIT
X-Cache-Hits:138631
X-Sylvanas:You walked right into this one, Arthas. It's time to even the scales.

steamreview.org:

Accept-Ranges:bytes
Connection:Keep-Alive
Content-Length:356994
Content-Type:image/png
Date:Fri, 01 Jul 2011 21:55:32 GMT
Etag:"9920019-57282-4a708fb079e00"
Keep-Alive:timeout=2, max=100
Last-Modified:Fri, 01 Jul 2011 21:48:40 GMT
Server:Apache

Comment 18

6 years ago
All provided links are WFM on Windows 7 x64 and both release and trunk, is somebody still able to reproduce this issue?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0
Whiteboard: [testday-20120713], [closeme 2012-08-01]
Please reopen this bug if it's reproducible in the latest Nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Whiteboard: [testday-20120713], [closeme 2012-08-01] → [testday-20120713]
You need to log in before you can comment on or make changes to this bug.