Download Manager does not open correct file when multiple files have the same name

VERIFIED DUPLICATE of bug 301328

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 301328
10 years ago
10 years ago

People

(Reporter: Mike, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

The download manager will not always open the correct file when multiple files have the same name. For example, if I am downloading a sequential set of videos, 1.mov, 2.mov, 3.mov, ... and then I download a different set of videos also named 1.mov, 2.mov, 3.mov, ... and try to open them from the download history list the 1.mov with a latter download time (thus from the second set downloaded) will open the 1.mov from the first download set. The behavior is erratic: 2.mov with a latter download time may open the correct movie from the second set, then 3.mov with the latter download time will open the video from the first set. Likewise the links to the first download set don't always open the correct movie. It would seem that there is only one link per name and if multiple files have the same name, only the one movie linked to that name can be opened. 

Reproducible: Always

Steps to Reproduce:
1.download a set of files with names one.mov two.mov or whatever
2.download another set of different files with the same names
3.try to open them from the download history list
I tried this with movies where I selected open instead of save to so they are downloaded to the temp cache. I did not try this with files downloaded to a different location.


Expected Results:  
Thought the list of files have similar names, they have different download times. I know which of the entries is which, but the list only handles one file per string in the list no matter the number of times the string appears

Updated

10 years ago
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 301328

Updated

10 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.