Closed Bug 437430 Opened 12 years ago Closed 8 years ago

Corrupted or missing .msf causes failure in rss feed updating, other errors

Categories

(MailNews Core :: Feed Reader, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: alta88, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: 3.0a2pre (2008060203) and branch as well


if a .msf file is corrupted (or missing) Tb will rebuild it upon folder selection, even displaying a statusbar message.  Tb is able to detect that a .msf file needs to be rebuilt.  however, it does not do so *unless* a folder is selected, despite various accesses that need the .msf file.

rss is one.  feeds will not update unless a .msf file is rebuilt or in a correct state.  neither will explicit actions such as rt click highlighting a folder for Get Messages, nothing happens.  on folder selection/rebuild, Get Messages works again.

another manifestation is this error thrown on folder hover, to get tooltips:
Error: Component returned failure code: 0x80550005 [nsIMsgFolder.getMsgDatabase] = <unknown>
Source file: chrome://messenger/content/mailWidgets.xml
Line: 2061

there may be other problems resulting from this.  the reason for .msf corruption isn't the point (i've had hard OS crashes, on a shared win/linux profile folder, for instance).

testcase: simply remove a running Tb rss folder's .msf file and hover on the folder, or try to Get Messages.

Reproducible: Always
Flags: wanted-thunderbird3?
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Severity: enhancement → normal
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20111115 Thunderbird/9.0

I see this issue in my current Thunderbird session, but the feeditems.rdf file has been rebuilt (= creation date) at a moment while I was not using Thunderbird. The feeds.rdf has been rebuilt later (maybe when I opened the subscriptions dialog).
well, i went and removed feeds dependency on the msgDdatabase .msf (switched to panacea) in Bug 705504 so this isn't going to stop feeds anymore.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.