New messages in a collapsed thread should not expand the entire thread

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Stephen Gallagher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs trunk test])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: version 2.0.0.14 (20080421)

When dealing with high-volume mailing lists, there can be dozens of responses on a particular thread. The default behavior of Thunderbird should not be to expand the thread if it is closed, as a very long thread can be difficult to navigate.

Reproducible: Always

Steps to Reproduce:
1. Join a high-volume mailing list.
2. Enable threading on the appropriate mail folder.
3. Note that when new messages come in on a collapsed thread, the entire thread is expanded.
Actual Results:  
All new messages fully expand their thread, possibly filling the email window to beyond a useable (user-friendly) display.

Expected Results:  
New messages arriving in a thread that is collapsed should be hidden, and only the underlining should occur to notify the user which thread contains unread messages.
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0

Comment 1

10 years ago
tested on version 3.0a1pre (2008050203) WinXP as follows

Steps
1. set the inbox in thread view
2. select a mail with few threads
3. click reply 
4. change to address to your own id
5. send mail
6. collapse the thread
7. do Get message from server

Actual Results:  
new message arrived, thread is marked with underline 
(BTW: if the thread was already underlined due to any existing unread message no further indication is shown)

So can we do WORKSFORME for this bug?
Or do you see things different when
* in Linux 
* with a mailing list.

(Reporter)

Comment 2

10 years ago
I have not tested this on Thunderbird 3.0a1. I have only verified its behavior on Thundebird 2.0 on Linux.

I will investigate on 3.0a1 later this week. Please do not yet close as WORKSFORME.

Comment 3

9 years ago
beta 1 is available
 http://www.mozillamessaging.com/en-US/thunderbird/early_releases/

Comment 4

8 years ago
(In reply to comment #3)
> beta 1 is available
>  http://www.mozillamessaging.com/en-US/thunderbird/early_releases/

please try beta 3
Whiteboard: [needs trunk test]

Comment 5

7 years ago
you haven't responded so we are closing this bug. version 3 has numerous
improvements. if you still see the problem in version 3.1 or newer, please
comment in the bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

7 years ago
Sorry, this long ago fell off my radar. This has worked for me since 3.0 final.
Resolution: INCOMPLETE → FIXED
You need to log in before you can comment on or make changes to this bug.