The default bug view has changed. See this FAQ.

pushlog should support query by date

VERIFIED FIXED

Status

Developer Services
Mercurial: hg.mozilla.org
P3
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: ted, Assigned: ted)

Tracking

Details

(URL)

(Assignee)

Description

9 years ago
The pushlog web interface should support querying for changesets in a date range, like bonsai does now.

Comment 1

9 years ago
Another option would be to specify a range of changesets, like, start and an optional end.
Found during triage. 


Ted, bsmedberg: who owns pushlog?
Component: Release Engineering → Release Engineering: Future
Priority: -- → P3
(Assignee)

Comment 3

9 years ago
bsmedberg and I have hacked on it, it doesn't have a real owner or a real home, which is why I filed this here. I don't think you guys should be on the hook for it, it just doesn't have a better place for bugs yet.

Updated

9 years ago
Duplicate of this bug: 437289

Comment 5

9 years ago
Ted you up to take this one :-)?
(Assignee)

Comment 6

9 years ago
Yeah, I'm working on some other pushlog stuff, so I can do it.
Assignee: nobody → ted.mielczarek

Updated

9 years ago
Component: Release Engineering: Future → Hg: Customizations
QA Contact: release → hg.customizations
(Assignee)

Comment 7

9 years ago
Pushed:
http://hg.mozilla.org/users/bsmedberg_mozilla.com/hgpoller/index.cgi/rev/7fbe834c1b97
http://hg.mozilla.org/index.cgi/hg_templates/rev/169ffa6c2879
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Ted, where can I access the pushlog to query for checkins within a given time frame? I cannot find any link on hgweb.
(Assignee)

Comment 9

9 years ago
http://hg.mozilla.org/mozilla-central/index.cgi/pushloghtml

Comment 10

9 years ago
This is awesome ted - can we get it linked to the basic changelog views on hgweb so it is more discoverable?
Thanks Ted, but some more questions. Perhaps they should be filed as new bugs:

* There is a link on the left side to switch to local time. If you click on that you don't have the chance to go back because there is no "To PSD" displayed. Can this be added?

* If you have clicked on "To Local" and you are trying to go back in using the back button, the result page with PSD times is not displayed. Instead the one week overview (initial URL) is opened.

* A query like "from 2008-08-16 00:00:00 to today" only shows the correct timeframe at the top but there is a huge list of entries in the middle which don't have displayed the checkin time. And I don't think that they went into mozilla-central at the same time.

* I agree with schrep, it should be better accessible

* Will Bonsai be updated to use hg or do we have to query hgweb directly from now?

That's all for now. Otherwise it looks fantastic!
(Assignee)

Comment 12

9 years ago
(In reply to comment #10)
> This is awesome ted - can we get it linked to the basic changelog views on
> hgweb so it is more discoverable?

I think we should make http://hg.mozilla.org/ show the pushloghtml page by default, and stop using changelog/shortlog completely, since they suck. I'll fix that at some point.

(In reply to comment #11)
> * There is a link on the left side to switch to local time. If you click on
> that you don't have the chance to go back because there is no "To PSD"
> displayed. Can this be added?

It could be, is it really that big of a deal? You can always just hit refresh.
 
> * If you have clicked on "To Local" and you are trying to go back in using the
> back button, the result page with PSD times is not displayed. Instead the one
> week overview (initial URL) is opened.

Yeah, it's just JavaScript, it's not navigating a page.

> * A query like "from 2008-08-16 00:00:00 to today" only shows the correct
> timeframe at the top but there is a huge list of entries in the middle which
> don't have displayed the checkin time. And I don't think that they went into
> mozilla-central at the same time.

Commits are grouped by push. It looks like you're seeing stuart's "Merging the mozilla-qt repository." merge+push, where he merged a bunch of checkins from another branch. That is in fact the time when they got pushed to mozilla-central.

> * I agree with schrep, it should be better accessible

Yeah, see above.

> * Will Bonsai be updated to use hg or do we have to query hgweb directly from
> now?

Bonsai is dead.
Ok, so I'm fine. Marking verified.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Blocks: 451012
Will this be implemented for other repositories (I'm thinking of comm-central and the different l10n repositories under l10n-central) as well?

Comment 15

9 years ago
pushlog belongs to the standard setup for all repos, and it's one centrally installed python module, so the features are the same across all repos.
(Assignee)

Updated

9 years ago
No longer blocks: 451012
Product: mozilla.org → Release Engineering
https://hg.mozilla.org/hgcustom/version-control-tools/rev/78114d5c97f7
https://hg.mozilla.org/hgcustom/version-control-tools/rev/5a66b276d513
Product: Release Engineering → Developer Services
You need to log in before you can comment on or make changes to this bug.