Menu "File -> New -> Calendar" is disabled in Mail Mode

VERIFIED FIXED in 0.9

Status

Calendar
Lightning Only
--
minor
VERIFIED FIXED
10 years ago
7 years ago

People

(Reporter: Stefan Sitter, Assigned: Fallen)

Tracking

unspecified
Bug Flags:
blocking-calendar0.9 +

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Lightning 0.9pre (2008060420) + Thunderbird 2.0.0.15pre (20080605) on WinXP

In Mail Mode the menu entry "File -> New -> Calendar" is disabled but creating new events and tasks is possible. One need to switch to Calendar or Task Mode to enable it.

I don't know if there is a reason for this behavior but the current situation just confuses users, e.g. <http://forums.mozillazine.org/viewtopic.php?t=662701>

Updated

10 years ago
Flags: wanted-calendar0.9+

Updated

10 years ago
Flags: wanted-calendar0.9+ → blocking-calendar0.9+
(Assignee)

Comment 1

10 years ago
Created attachment 327309 [details] [diff] [review]
Fix v1
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #327309 - Flags: review?(Berend.Cornelius)
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → 0.9

Comment 2

10 years ago
Comment on attachment 327309 [details] [diff] [review]
Fix v1

r=berend
Attachment #327309 - Flags: review?(Berend.Cornelius) → review+
(Assignee)

Comment 3

10 years ago
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 4

10 years ago
Checked in lightning 2008070305 -> VERIFIED.
Status: RESOLVED → VERIFIED

Comment 5

9 years ago
Related to this fix,  Bug 459356 , shows a problem where the File -> New -> Calendar option is disabled in all modes.

Updated

7 years ago
Duplicate of this bug: 537451
Anyone following http://hg.mozilla.org/mozilla-central/rev/3f8ae66d0015 (landed with this bug number), see Bug 537451.
You need to log in before you can comment on or make changes to this bug.