Listing of FTP site contents are often stale, cache is wonky

RESOLVED WONTFIX

Status

()

Core
Networking: FTP
--
minor
RESOLVED WONTFIX
10 years ago
2 years ago

People

(Reporter: matneh, Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
wanted1.9.1 ?

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

In accessing an FTP site, it seems Firefox is caching the contents.  That is fine, and I'll hit Reload when I know a file has been added.  But when I navigate up a directory and back to the original location, the cached contents are old, even though I performed a manual refresh.

Reproducible: Always

Steps to Reproduce:
1. Go to an FTP server directory "foo/"
2. On the side, add a file to that directory
3. Hit Refresh, the file should appear
4. Click on "Up to higher level directory"
5. Click on "foo/" again

Actual Results:  
The new file is not in the listing.

Expected Results:  
The new file should be in the listing

Updated

10 years ago
Component: General → Networking: FTP
Product: Firefox → Core
QA Contact: general → networking.ftp

Comment 1

10 years ago
This could have the same reason as bug #445791

Comment 2

9 years ago
Can confirm this. Requesting it fixed for 3.1
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted1.9.1?
Duplicate of this bug: 523810
if anything - we will rip out ftp. enhancements belong in addons
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.