File properties tab suggestions

VERIFIED WORKSFORME

Status

SeaMonkey
Bookmarks & History
P3
trivial
VERIFIED WORKSFORME
17 years ago
5 years ago

People

(Reporter: pete, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({qawanted})

Trunk
x86
Windows NT
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I think the tabs in the file properties are actually buttons instead of real 
tabs.

Comment 1

17 years ago
pete_a90@yahoo.com (JakieChan), I don't understand this report at all.  Can you 
please explain the bug more.
(Reporter)

Comment 2

17 years ago
What I'm saying is, http://www.mozilla.org/xpfe/xulref/boxref.html says 
the "vertical" or "horizontal" values for the align attribute are depreciated 
and suggests to use orient attribute for this instead. However, tabcontrol.css 
uses align="vertical" align="horizontal" to decide how to render the tabs to 
make them look like tabs and not buttons. Since I can't find an xul.dtd I do 
not know for sure which values are default for properties. Anyways, as you can 
see the tabs in the bookmarks property sheet do not render looking like a tab 
because it doesn't list the alignment according to tabcontrol.css. This also 
happens in all the places I've bothered looking for that uses <tab> but bm-
props.xul is where I noticed this first.

Comment 3

17 years ago
adding ben and rjc to the bug.

Comment 4

17 years ago
m19
Target Milestone: --- → M19

Comment 5

17 years ago
with a milestone set, confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
Reassigning 79 Bookmarks bugs to Ben.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → ben

Comment 7

17 years ago
The tabs in the bookmark properties sheet look like tabs to me... 

bm_props.xul:
<tabcontrol orient="vertical">
  <tabbox>
    <tab value="&generalInfo.label;" accesskey="&generalInfo.accesskey;"/>
    <tab id="ScheduleTab" value="&schedule.label;" 
accesskey="&schedule.accesskey;"/>
  </tabbox>
  <tabpanel>

etc.

Is this invalid?
Netscape Nav triage team: this is not a Netscape beta stopper.
Keywords: nsbeta1-

Comment 9

17 years ago
If this is a bookmarks issue, is it still relevent following Ben's re-write of
Bookmarks in recent weeks? Adding qawanted keyword.
Keywords: qawanted

Comment 10

16 years ago
this looks like a WFM based on Matthew's comments and looking at the 2001030608 builds
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 11

16 years ago
with reckless disregard to independent verification (and b/c I'm pretty sure) marking
VERIFIED WFM
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.