Allow bandwidth limit controls for the Download Manager

VERIFIED DUPLICATE of bug 298252

Status

()

VERIFIED DUPLICATE of bug 298252
11 years ago
10 years ago

People

(Reporter: ariel_l53, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008053008 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008053008 Firefox/3.0

When downloading files, allow control of download rate. For example, if I'm downloading a new version of Thunderbird and don't want to hog my bandwidth, I'd like to be able to set a download speed so it takes up no more than a specified amount of KB/s.

So, I would be able to start download the file or program, open the download window, and see an option to limit download speed to say, 30 KB/s, letting it download reasonably quickly while still leaving enough bandwidth for me to surf the web without delays.

There can also be separate preferences to set hours where different rates can be used.

The BitTorrent client "Transmission" for Linux and Mac has bandwidth limitation settings similar to what I am requesting.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 298252
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.