[quirks] text-decoration not drawn in block inside inline

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
4 years ago

People

(Reporter: fathim, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

I am using Firefox 3.0 RC for browsing Arai Arabic newspaper (http://www.alrai.com). The articles’ titles are underlined, when browsing he same page in IT 6.x, it displays the links correctly “not underlined”.

I am attaching two screen shots to explain the problem ..


Reproducible: Always

Steps to Reproduce:
1.visit http://www.alrai.com
2.
3.
Actual Results:  
links in the home page (left side) are underlined 

Expected Results:  
it shouldn't be underlined .. compare to IE

please check attached screen shots
(Reporter)

Comment 1

11 years ago
Created attachment 324049 [details]
screen shots show the page display as it should be (as in IE), and how it is displayed in Firefox...

Comment 2

11 years ago
First of all, please, please, don't attach Word documents, especially just for images.  (and, I only see one image in that file)  Just attach the image files.

Secondly, my guess is that this is the fault of some CSS coding in the site itself.  It looks the same in Firefox 2 and Firefox 3, near as I can tell.  Just because it "works in IE", doesn't mean that it's broken in Firefox.  There's two other possibilities:  1. Broken in IE and works in Firefox; 2. They're using browser specific code for everything and screwed up. (which is all too common)

This might be a TE bug, but I'll let someone else decide that.

Comment 3

11 years ago
Created attachment 324084 [details]
Testcase #1 (Quirks mode)

Comment 4

11 years ago
Created attachment 324085 [details]
Testcase #2 (Standards mode)

Comment 5

10 years ago
Quirks and Standards mode are using different code for text decoration, see Bug 403524. So I think this bug is either dependent or a duplicate of one of the many text-decoration bugs. I'll confirm it for now.
Status: UNCONFIRMED → NEW
Component: General → Layout: Text
Ever confirmed: true
Product: Firefox → Core
Summary: links are underlined → [quirks] text-decoration not drawn in block inside inline
Version: unspecified → Trunk
QA Contact: general → layout.fonts-and-text

Comment 6

4 years ago
-> INVALID (most likely),
assuming the "bug" here is the underline in Testcase #1 (Quirks mode).
This do other browsers as well, tested with:
IE11 (but no underline in IE7-10), Chrome 34, Safari 5.1, Opera 12.17
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.