Firefox 3 rc2 hangs on startup under mac os x 10.5.3

VERIFIED DUPLICATE of bug 436575

Status

()

--
critical
VERIFIED DUPLICATE of bug 436575
10 years ago
10 years ago

People

(Reporter: e.christodoulou, Unassigned)

Tracking

1.9.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008053008 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008053008 Firefox/3.0

Date/Time:      2008-06-07 10:33:48 +0200
OS Version:     10.5.3 (Build 9D34)
Architecture:   i386
Report Version: 4

Command:        Firefox
Path:           /Applications/Firefox.app/Contents/MacOS/firefox-bin
Version:        3.0 (3.0)
Parent:         launchd [62]

PID:            1646
Event:          hang
Time:           14.21s
Steps:          109


Process:        firefox-bin [1646]
Path:           /Applications/Firefox.app/Contents/MacOS/firefox-bin

  ADDRESS         BINARY
  00001000        /Applications/Firefox.app/Contents/MacOS/firefox-bin
  00005000        /Applications/Firefox.app/Contents/MacOS/libxpcom.dylib
  0000a000        /Applications/Firefox.app/Contents/MacOS/libplds4.dylib
  00014000        /Applications/Firefox.app/Contents/MacOS/libplc4.dylib
  00035000        /Applications/Firefox.app/Contents/MacOS/libnspr4.dylib
  0006a000        /Applications/Firefox.app/Contents/MacOS/libsmime3.dylib
  0009f000        /Applications/Firefox.app/Contents/MacOS/libmozjs.dylib
  0013e000        /Applications/Firefox.app/Contents/MacOS/libsqlite3.dylib
  0019d000        /Applications/Firefox.app/Contents/MacOS/libssl3.dylib
  001cf000        /Applications/Firefox.app/Contents/MacOS/libnss3.dylib
  002bb000        /Applications/Firefox.app/Contents/MacOS/libnssutil3.dylib
  002d1000        /Applications/Firefox.app/Contents/MacOS/libsoftokn3.dylib
  00350000        /Applications/Firefox.app/Contents/MacOS/components/libbrowserdirprovider.dylib
  003da000        /Applications/Firefox.app/Contents/MacOS/components/libalerts_s.dylib
  0064a000        /System/Library/CoreServices/Encodings/libSimplifiedChineseConverter.dylib
  0078e000        /Applications/Firefox.app/Contents/MacOS/libnssdbm3.dylib
  007b1000        /Applications/Firefox.app/Contents/MacOS/libnssckbi.dylib
  00a31000        /Applications/Firefox.app/Contents/MacOS/libfreebl3.dylib
  00c9a000        /Applications/Firefox.app/Contents/MacOS/XUL
  297e9000        /System/Library/TextEncodings/Unicode Encodings.bundle/Contents/MacOS/Unicode Encodings
  29f9b000        /Applications/Firefox.app/Contents/MacOS/components/libbrowsercomps.dylib
  2a7fa000        /System/Library/CoreServices/RawCamera.bundle/Contents/MacOS/RawCamera
  ba900000        /System/Library/CoreServices/Encodings/libJapaneseConverter.dylib


Reproducible: Always

Steps to Reproduce:
1.
2.
3.



  Thread id:      8b61ba0
  User stack:
    109 start + 41 (in firefox-bin) [0x1acd]
      109 start + 270 (in firefox-bin) [0x1bb2]
        109 start + 641 (in firefox-bin) [0x1d25]
          109 _XRE_main + 13279 (in XUL) [0xca2613]
            109 _XRE_GetFileFromPath + 6407699 (in XUL) [0x12d51d1]
              109 _JSD_GetValueForObject + 711454 (in XUL) [0x140ec29]
                109 -[NSApplication run] + 795 (in AppKit) [0x922dadf3]
                  109 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128 (in AppKit) [0x922e1db8]
                    109 __DPSNextEvent + 657 (in AppKit) [0x922e2505]
                      109 _BlockUntilNextEventMatchingListInMode + 106 (in HIToolbox) [0x95e41a31]
                        109 _ReceiveNextEventCommon + 374 (in HIToolbox) [0x95e41bbd]
                          109 _RunCurrentEventLoopInMode + 283 (in HIToolbox) [0x95e41da4]
                            109 _CFRunLoopRunInMode + 88 (in CoreFoundation) [0x92e3dcf8]
                              109 _CFRunLoopRunSpecific + 3166 (in CoreFoundation) [0x92e3d60e]
                                109 _JSD_GetValueForObject + 714456 (in XUL) [0x140f7e3]
                                  109 _JSD_GetValueForObject + 892122 (in XUL) [0x143ade5]
                                    109 __Z18GetSecurityContextP7JNIEnv_PP18nsISecurityContext + 194963 (in XUL) [0x1479e6f]
                                      109 _NS_GetComponentRegistrar_P + 28531 (in XUL) [0x14af2fb]
                                        109 __ZNSt6vectorItSaItEE14_M_fill_insertEN9__gnu_cxx17__normal_iteratorIPtS1_EEmRKt + 95964 (in XUL) [0x15facce]
                                          109 _XRE_GetFileFromPath + 2924907 (in XUL) [0xf82d29]
                                            109 _XRE_GetFileFromPath + 1166799 (in XUL) [0xdd598d]
                                              109 _XRE_GetFileFromPath + 1172403 (in XUL) [0xdd6f71]
                                                109 _XRE_GetFileFromPath + 1162272 (in XUL) [0xdd47de]
                                                  109 _XRE_GetFileFromPath + 1128776 (in XUL) [0xdcc506]
                                                    109 _XRE_GetFileFromPath + 1132551 (in XUL) [0xdcd3c5]
                                                      109 _XRE_GetFileFromPath + 1128116 (in XUL) [0xdcc272]
                                                        109 _XRE_GetFileFromPath + 1114691 (in XUL) [0xdc8e01]
                                                          109 _XRE_GetFileFromPath + 3696472 (in XUL) [0x103f316]
                                                            109 _XRE_GetFileFromPath + 3694896 (in XUL) [0x103ecee]
                                                              109 _XRE_GetFileFromPath + 3689711 (in XUL) [0x103d8ad]
                                                                109 _XRE_GetFileFromPath + 3616503 (in XUL) [0x102bab5]
                                                                  109 _XRE_GetFileFromPath + 3228136 (in XUL) [0xfccda6]
                                                                    109 _XRE_GetFileFromPath + 3239939 (in XUL) [0xfcfbc1]
                                                                      109 _XRE_GetFileFromPath + 3234466 (in XUL) [0xfce660]
                                                                        109 _XRE_GetFileFromPath + 3233620 (in XUL) [0xfce312]
                                                                          109 _XRE_GetFileFromPath + 4273443 (in XUL) [0x10cc0e1]
                                                                            109 _JS_EvaluateUCScriptForPrincipals + 134 (in libmozjs.dylib) [0xa55d7]
                                                                              109 _js_Invoke + 4096 (in libmozjs.dylib) [0xda913]
                                                                                109 _JS_CompareValues + 5380 (in libmozjs.dylib) [0xce101]
                                                                                  109 _js_LookupProperty + 7526 (in libmozjs.dylib) [0xe67bf]
                                                                                    109 _JS_FloorLog2 + 18506 (in libmozjs.dylib) [0xe1715]
                                                                                      109 _js_Invoke + 2599 (in libmozjs.dylib) [0xda33a]
                                                                                        109 _js_Invoke + 2309 (in libmozjs.dylib) [0xda218]
                                                                                          109 _js_Invoke + 1834 (in libmozjs.dylib) [0xda03d]
                                                                                            109 _XRE_GetFileFromPath + 188998 (in XUL) [0xce6e04]
                                                                                              109 _XRE_GetFileFromPath + 169803 (in XUL) [0xce2309]
                                                                                                109 _NS_InvokeByIndex_P + 81 (in XUL) [0x14ba9bd]
                                                                                                  109 _XRE_GetFileFromPath + 6837664 (in XUL) [0x133e15e]
                                                                                                    109 _XRE_GetFileFromPath + 6894818 (in XUL) [0x134c0a0]
                                                                                                      109 _XRE_GetFileFromPath + 6894225 (in XUL) [0x134be4f]
                                                                                                        109 _XRE_GetFileFromPath + 6893848 (in XUL) [0x134bcd6]
                                                                                                          109 _XRE_GetFileFromPath + 6890816 (in XUL) [0x134b0fe]
                                                                                                            109 _XRE_GetFileFromPath + 6923388 (in XUL) [0x135303a]
                                                                                                              109 _CFBundleCopyExecutableURL + 58 (in CoreFoundation) [0x92de204a]
                                                                                                                109 __CFBundleCopyExecutableURLInDirectoryWithAllocator + 260 (in CoreFoundation) [0x92de1c14]
                                                                                                                  109 __CFBundleCopyExecutableURLRaw + 399 (in CoreFoundation) [0x92de11af]
                                                                                                                    109 _stat64 + 10 (in libSystem.B.dylib) [0x9095108e]
  Kernel stack:
    109 _unix_syscall + 572 [0x3dddda]
      109 _stat64 + 72 [0x1e484c]
        109 _munge_stat + 1385 [0x1e4769]
          109 _munge_stat + 325 [0x1e4345]
            109 _namei + 1237 [0x1d5731]
              109 _lookup + 661 [0x1d49ac]
                109 _VNOP_LOOKUP + 110 [0x1f2e9a]
                  109 _hfs_swap_BTNode + 25582 [0x3271ac]
                    109 _CompareExtendedCatalogKeys + 22132 [0x31e8ba]
                      109 _CompareExtendedCatalogKeys + 19397 [0x31de0b]
                        109 _vnode_removefsref + 302 [0x1da527]
                          109 _msleep + 157 [0x380a25]
                            109 _uiomove + 653 [0x380674]
                              109 _lck_mtx_sleep + 87 [0x130a21]
                                109 _thread_block + 33 [0x136ac0]
                                  109 _thread_continue + 1181 [0x136853]
(Reporter)

Comment 1

10 years ago
Created attachment 324127 [details]
Hang report as generated by Apple's Finder
(Reporter)

Comment 2

10 years ago
Hardware Overview:

  Model Name:	iMac
  Model Identifier:	iMac8,1
  Processor Name:	Intel Core 2 Duo
  Processor Speed:	2.8 GHz
  Number Of Processors:	1
  Total Number Of Cores:	2
  L2 Cache:	6 MB
  Memory:	4 GB
  Bus Speed:	1.07 GHz
  Boot ROM Version:	IM81.00C1.B00
  SMC Version:	1.30f1
Version: unspecified → 3.0 Branch

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 436575

Updated

10 years ago
Status: RESOLVED → VERIFIED
This bug might not be a dup of bug 436575, but instead just related to
it.  Please try the tryserver build from bug 436575 comment #38 to see
if it makes your hangs go away.
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> This bug might not be a dup of bug 436575, but instead just related to
> it.  Please try the tryserver build from bug 436575 comment #38 to see
> if it makes your hangs go away.
> 

I'll try it and report back.
Thanks for looking into this.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.