HTML content ignored in messages not comply with RFC2046

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
2 years ago

People

(Reporter: hantwister, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

15.72 KB, message/rfc822
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; InfoPath.1; .NET CLR 3.0.04506.648)
Build Identifier: 20080421

In an e-mail sent from the Linksys RMA Department, both a text/html section encoded in base64 and a text/plain section encoded in quoted-printable were present, but Thunderbird, for an unknown reason, displayed the text/plain content, even though it was set to display "Original HTML".

Reproducible: Always

Steps to Reproduce:
1. Receive RMA E-Mail From Linksys RMA Department (Example Attached).
2. Attempt to open with Thunderbird.
Actual Results:  
Thunderbird displays the text/plain content, instructing the user to open the e-mail with an HTML-capable e-mail client.

Expected Results:  
Thunderbird should have displayed the text/html content.
(Reporter)

Comment 1

10 years ago
Created attachment 324134 [details]
Testcase

Comment 2

10 years ago
confirm on version 3.0a2pre (2008060703)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Comment 3

10 years ago
According to RFC 2046:

"the order of body parts is significant.  In this case, the alternatives
appear in an order of increasing faithfulness to the original content.  
In general, the best choice is the LAST part of a type supported by the 
recipient system's local environment."

In this message the plain text part is last.

Probable duplicate of the now somewhat confused bug 108010.

Perhaps this bug should be an enhancement request to provide the user with a way to selected which part to display.

Comment 4

10 years ago
I think make changes for broken messages not good idea but still we can have some option in config editor to make this work.
Summary: Thunderbird Ignores HTML Content In E-Mail From Linksys RMA Department → HTML content ignored in messages not comply with RFC2046
FYI.
Bug 130119 is RFE of "user's choice of part".
> Option to choose what part of multipart/alternative message to display

Comment 6

2 years ago
attachment 324134 [details] displays the HTML content for me. Closing as WFM.

Thunderbird 45.8.0
Windows 7 64-bit
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.