Closed Bug 437840 Opened 12 years ago Closed 12 years ago

File types starting with vowels cause grammar error in download confirmation dialog

Categories

(Toolkit :: Downloads API, defect, trivial)

defect
Not set
trivial

Tracking

()

VERIFIED DUPLICATE of bug 224315

People

(Reporter: pmjshields, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

The download confirmation dialog typically reads:

"You have chosen to open
[file name]
which is a: [file type]
from: [site url]"

When the file name starts with a vowel, e.g. "Application", the dialog will say

"which is a: Application"

Suggest changing the text to avoid this aesthetic issue. Solutions include changing the text so it doesn't end in an article (1) or removing the continous sentence style from the dialog entirely (2).

(1)
"which is a file of type:"

(2)
"You have chosen to open the following file.
[file name]
File Type: [file type]
Location: [site url]"

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
Phrase with wrong article agreement ("a" + word starting in consonant) is displayed.


This may affect other languages with similar rules to English.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 224315
v dupe.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.