If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

JavaScript stops working completely.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Scott Yeskie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I have had recurring problems with JavaScript being completely inoperable. I have JavaScript enabled, and have never installed the NoScript extension. It has been happening on and off across all sites for the past couple weeks in FF RC1 and RC2. A restart (of browser or computer) does not specifically fix the problem. However, it does go away after an unknown time (days usually).

Reproducible: Sometimes

Steps to Reproduce:
This works nearly all of the time.
1. Watch long Flash movies (>30mins)
2. Navigate to another page.

However, that isn't the only time it's occurred for me. Beyond the above example, I have not been able to detect any discernible pattern.
Actual Results:  
JavaScript does not work: Flash videos don't load; redirects, javascript functions don't work, websites tag the browser as not having javascript enabled.

Expected Results:  
JavaScript working.

I do have the Web Developer toolbar installed. From the latest nonfunctional site (www.dhl.com), I do have the following warnings in the error console:

Warning: assignment to undeclared variable gVersion
Source File: http://www.dhl.com/
Line: 35

Warning: assignment to undeclared variable myMeta
Source File: http://www.dhl.com/
Line: 143

Warning: test for equality (==) mistyped as assignment (=)?
Source File: http://www.dhl.com/
Line: 215, Column: 32
Source Code:
if(dhlcomVal=GetCookie('dhlcom')){ 
-------------------------------- ^

Warning: assignment to undeclared variable dhlcomVal
Source File: http://www.dhl.com/
Line: 215

That site is not the problem, as it works in FF 2 on Linux and was working in the same Windows FF 3 RC2 browser within the past week.

Comment 1

9 years ago
Does the problem still exist in Safe Mode?
(Reporter)

Comment 2

9 years ago
Yes, it still happens in safe mode.
(Reporter)

Comment 3

9 years ago
Looking at it some more, since it's still in one of its non-JavaScript fits, I'm not sure that it's a Firefox bug. I just tried in 2 additional browsers on the same computer (installed several for web design awhile back) and all three acted like they didn't have JavaScript.

Mozilla
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.11) Gecko/20050728

Opera
Opera/9.50 (Windows NT 5.1; U; en)

(Tested just the DHL site. That site still works from Firefox 2 on my Linux machine)

Does JavaScript use a shared driver/library in Windows, perhaps, that might be causing this?
Javascript doesn't use a system libary at all and the JS Engine in Mozilla should be very different from the Opera JS Engine.

And without Javascript you couldn't use the Mozilla and Firefox UI because they are XUL+Javascript.

Maybe your are using a Firewall / Proxy / Anti-virus which is filtering ?
(Reporter)

Comment 5

9 years ago
Well, it's started working again with no apparent reason. Next time it cuts out I'll check that. However, there's nothing unique about it. I've been using the same setup for over a year now. Norton Internet Security 2003 and BitDefender Anti-Virus 10. Norton has had personal firewall enabled, Windows Firewall has been disabled, and I don't use a proxy.

Also, I just checked Opera and it still isn't working. So it was apparently an unrelated coincidence that it didn't work. I just rarely use it so I hadn't caught that.
marking wfm in that case
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.