Closed Bug 437932 Opened 12 years ago Closed 12 years ago

mozilla cannot "translate" backslashes in a link and connects to an error page

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 73701

People

(Reporter: wholeheartfriend, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Firefox is not able to connect to the right page, when backslashes are used in a link. I thought that ONLY SLASHES were allowed. I wrote to W3C validation helpdesk/forum about this, and the reply was that SLASHES AND BACKSLASHES in a link are permitted. So the question is, why can't Firefox connect to the right page when backslahses are used in a link? IE (go figure) is able to do so. Opera as well.
Hopefully this error can be changed asap.


Reproducible: Always

Steps to Reproduce:
1. just make a link with backslahses in it, and test it out.
2.
3.
Slashes and backslashes are certainly permitted in a URL, however they are not the same character and so should not give the same result. You are probably hoping for Firefox to automatically replace any backslashes with forward slashes before requesting the page, this is what IE does.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 73701
You need to log in before you can comment on or make changes to this bug.