If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Website renders incorrectly on Solaris

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
minor
RESOLVED WORKSFORME
18 years ago
3 years ago

People

(Reporter: Brandon Hume, Assigned: Marc Attinasi)

Tracking

Trunk
mozilla1.0
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The specified website will not render properly with the latest nightlies
(for the past couple of weeks), the mozilla-sparc-solaris-2.6 builds
running on Solaris 8.

Immediate examples are the "headlines" block being placed over top of the
sidebar, and the appearance of "image\trans" (which appears to be the name
of the graphical bars on either site of the main news area).

The website renders perfectly using the latest nightlies on Win32.

Comment 1

18 years ago
Ok, second try. [I tried to use mozilla to add a comment to this bug, but
mozilla crashed while I was entering the comments... :( ]

I loaded http://www.voodooextreme.com/ with both
- PC/Linux build 2000063020 and 
- Sun/Solaris2.6 build 2000062921.
I could not find any differences.

I do *not* see anything ``being placed over top of the sidebar''.
Maybe this only occurs if you run the solaris-2.6 build on solaris-8?
As far as this problem is concerned, I recommend worksforme.

I *do* see the ``images\trans'' text screwing up the page. This is closely
related to bug 41924 "Change how layout handles broken images".
Reassigning to the owner of that bug.

Ian -- can you comment on the second issue?

If there are more problems on this page, please open new bugs for each of them,
but only one problem per bug and only after searching for similar bugs.
For solaris-specific bugs, it could also help some people if you compare the
behaviour on Solaris and Linux and describe the difference.
(Of course, that requires access to a linux machine...)
Assignee: clayton → nisheeth
(Reporter)

Comment 2

18 years ago
I'm afraid I didn't think of it as two separate issues when I filed... I was
stuck in "it does one thing on Windows and something different on Solaris".
I considered that to be a bit odd for the rendering engine.

The different table cells appearing on top of each other appears to have gone
away.  However, I can still get the "image\trans"... and my main concern was,
it doesn't do it on Win32.  If they BOTH displayed it, fine, or if they both
didn't.  But why the difference?  Bug 41924 doesn't appear to be architecture
specific.
(Reporter)

Comment 3

18 years ago
Just checked Voodooextreme, it no longer has the problems I mentioned.  Whether
something changed in the browser or on the site, I dunno, it doesn't matter at
this point.

Voodooextreme is still an exceptional piece of murder for Mozilla, but that's
something different altogether.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
This bug is still happening, but it seems to depend on the size of the browser 
window.  Keep shrinking the horizontal size of the browser, and eventually, 
you'll see this bug.  Conversely, if you expand the horz. size, the problem goes 
away at some point.  However, the same size window with Netscape 4.7x and IE 4.x 
doesn't have the problem.

Comment 5

17 years ago
That's true. I'm seeing it on Linux with a build from today. Sounds like a
cross-platform problem. Maybe this bug should be reopened? 
Or are there any other open bugs about this?

Comment 6

17 years ago
Some more details: I have my sidebar turned off completely, and my fonts set to
13 pixel size.  Some experiments showed that a browswer window width of 738
pixels was okay, but 737 pixels (or less) triggered the problem.  I'm guessing a
lot of people have their browser set larger than this, and that's why they're
not seeing it.

Comment 7

17 years ago
I'd like to suggest this bug be reopened, as it definitely still occurs.

Comment 8

17 years ago
Reopening per request.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

17 years ago
Chris, this one belongs to your group.
Assignee: nisheeth → karnaze

Comment 10

17 years ago
Unfortunately, VoodooExtreme changed their page layout a lot recently, so that
this bug is no longer triggered.  I'm pretty sure I've seen the problem on some
other pages, but I can't give a specific page right now.  Just noting this so no
one wastes time trying to reproduce it.  I suspect the bug still exists, but I
just don't know how to trigger it anymore.

Updated

17 years ago
Keywords: qawanted

Comment 11

17 years ago
Triaging karnaze's bugs. Marc, would it be yours?
Assignee: karnaze → attinasi
Target Milestone: --- → mozilla1.0

Comment 12

16 years ago
win32 trunk build from 2001-09-21. WFM
mac trunk build from 2001-09-21. WFM

Comment 13

16 years ago
WFM too, but as I noted, the actual layout on the site has changed, so there's
no way to know if this bug is still around.  But I suppose this should be
resolved as WFM, and a new bug opened if it's ever found again.

Comment 14

16 years ago
Per comments made (layout now changed), marking bug WORKSFORME. Reporter, if bug
still exists, please reopen and provide another testcase - thanks
Status: NEW → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.