Every time a buglist has no bugs, a JS error is thrown (exception thrown for query with no results)

RESOLVED WORKSFORME

Status

()

bugzilla.mozilla.org
General
--
minor
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Frédéric Buclin, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
On b.m.o, run a query which returns no bugs. The following JS error is thrown due to sorttable.js:

Erreur : [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIDOMHTMLTableSectionElement.appendChild]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: https://bugzilla.mozilla.org/js/sorttable.js :: anonymous :: line 50"  data: no]
Fichier Source : https://bugzilla.mozilla.org/js/sorttable.js
Ligne : 50

It seems it tries to add <thead> despite there is no table as there is no bugs found. We should first check if the table exists and do nothing if not.
Summary: Every time a buglist has no bugs, a JS error is thrown → Every time a buglist has no bugs, a JS error is thrown (exception thrown for query with no results)
(Reporter)

Updated

10 years ago
Duplicate of this bug: 456333
Duplicate of this bug: 474384
I don't get the error given above in Firefox 4.0 beta 8 on today's bmo.

Gerv
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
I'd be surprised if it's gone...
(Assignee)

Updated

7 years ago
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.