Hang if dragging picture during javascript alert

VERIFIED DUPLICATE of bug 100180

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 100180
10 years ago
10 years ago

People

(Reporter: Travis Vignon, Unassigned)

Tracking

({hang})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

If you sign up for this site (free) and log into this page, you will get a small picture with white pixels on a black background. When the page loads a timer counts down to a javascript alert after 15 seconds. If you attempt to drag that (or any) picture when the alert finally pops up, it will crash the browser. You can still see the pages on the screen, but no buttons or menus can be accessed and it must be killed in Task Manager.

Reproducible: Always

Steps to Reproduce:
1.Log into the above site and navigate to that URL
2. On page load, drag picture with white pixels on black bkgd around for at least 15 seconds.
3. Once javascript alert fires, browser will stop functioning.
Actual Results:  
Drag stopped in mid-drag, alert stayed on screen but was unable to be accessed. No other menus or buttons could be accessed until FF was stopped and restarted.

Expected Results:  
Since javascript alerts take active control until you close them, I would assume that the drag would need to be cancelled altogether and then restarted after the alert has been satisfied.

No themes or add-ons. 100% default except for some saved passwords and an altered home address.

about:buildconfig

Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-GL -wd4624 -wd4952 -TC -nologo -W3 -Gy -Fd$(PDBFILE)
cl 	14.00.50727.762 	-GR- -GL -wd4624 -wd4952 -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-official-branding --enable-jemalloc --with-crashreporter-enable-percent=25
Sounds like a dupe of / related to Bug 100180.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 100180
V.Duplicate
Status: RESOLVED → VERIFIED
Keywords: hang
Summary: Crash if dragging picture during javascript alert → Hang if dragging picture during javascript alert
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.