If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

new calender entry direct after start crashed

RESOLVED DUPLICATE of bug 327933

Status

Calendar
Lightning Only
RESOLVED DUPLICATE of bug 327933
9 years ago
9 years ago

People

(Reporter: pv, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: this.eventNameTextbox has no properties 

start thunderbird (2.0.0.14 20080421 german) or Portable, select calender Lightning (0.8  2008033120) first and create new calender entry throw exception:
Fehler: this.eventNameTextbox has no properties
Quelldatei: chrome://calendar/content/calendar-view-core.xml
Zeile: 288

Use first one exist calender entry and browse this, crashed following created not.

FYI: I have WebDAV calender file.


Reproducible: Always

Steps to Reproduce:
1.start thunderbird (2.0.0.14 20080421 german) or Portable
2.select calender Lightning (0.8  2008033120)
3.create new calender entry
Actual Results:  
          if (saveChanges && (this.eventNameTextbox.value != this.mOriginalTextLabel)) {
              this.calendarView.controller.modifyOccurrence(this.mOccurrence, 
                                                            null, null,
                                                            this.eventNameTextbox.value);


this.eventNameTextbox.value do not exist in the time


Expected Results:  
new entry create
(Reporter)

Comment 1

9 years ago
Bug exists only with WebDAV over WinXP with IIS 5.1. About FTP is running correctly
Could you test this with a recent nightly version (0.9pre) from
ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-mozilla1.8 ?
(Reporter)

Comment 3

9 years ago
I have tested.
same Error:
There has been an error reading data for calendar: PeVo. It has been placed in read-only mode, since changes to this calendar will likely result in data-loss.  You may change this setting by choosing 'Edit Calendar'.
error number:0x0
Publishing the calendar file failed
Status code: 412: Precondition Failed

konsole:
Fehler: this.eventNameTextbox has no properties
Quelldatei: chrome://calendar/content/calendar-view-core.xml
Zeile: 301
[          if (saveChanges && (this.eventNameTextbox.value != this.mOriginalTextLabel)) {
              this.calendarView.controller.modifyOccurrence(this.mOccurrence, 
                                                            null, null,
                                                            this.eventNameTextbox.value);]





new others/follows errors whith alarm by start:

Fehler: [Exception... "'<error>' when calling method: [calICalendar::deleteItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///C:/Test/ThunderbirdPortable.lief/Data/profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calTransactionManager.js :: cT_doTransaction :: line 182"  data: no]
Quelldatei: file:///C:/Test/ThunderbirdPortable.lief/Data/profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calTransactionManager.js
Zeile: 182

and follows errors by entry delete after alarm:

Fehler: uncaught exception: [Exception... "'<error>' when calling method: [calICalendar::deleteItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///C:/Test/ThunderbirdPortable.lief/Data/profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calTransactionManager.js :: cT_doTransaction :: line 182"  data: no]


Comment 4

9 years ago
The 412: Precondition Failed error indicates that the server rejected writing the calendar file due to a HTTP ETag mismatch. See Bug 327933 for same error.

The 0x804a0002 errors just indicate that the calendar is read-only and Lightning refuses to change it (Bug 313640).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 327933
You need to log in before you can comment on or make changes to this bug.